Graphical corruption on page content

VERIFIED DUPLICATE of bug 787732

Status

()

--
major
VERIFIED DUPLICATE of bug 787732
7 years ago
7 years ago

People

(Reporter: MichaelRL100, Unassigned)

Tracking

({regression})

18 Branch
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(firefox18 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 657899 [details]
1346628352383.jpg

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20120828190521

Steps to reproduce:

I go to certain websites, for example the website that I am currently having this issue with (and the easiest website to reproduce this on) is Wikipedia. I go to any article, and expand one of the drop-down arrows for a section of the article.


Actual results:

Black squares, rectangles, and multicolored visual artifacts appear on the screen. This bug happens when hardware acceleration is enabled, and when I disable hardware acceleration, the entire page (no matter what page I load, sometimes even the about: pages) will go completely black.


Expected results:

As with the earlier Firefoxes, I expected no visual artifacts to appear.
(Reporter)

Updated

7 years ago
Severity: normal → major
OS: Linux → Android
Hardware: x86_64 → ARM
(Reporter)

Comment 1

7 years ago
I'm running a modded Motorola Triumph with CM7 MTDEV (the latest version). I tried clearing data under settings, uninstalling and reinstalling, but the bug persists. This bug started a little after the Firefox 18 Nightlies started coming out. This bug did not occur on this ROM with those earlier Nightlies, so my guess is this effects other phones as well. It also may occur on stock. Can anybody confirm this?
(Reporter)

Comment 2

7 years ago
By the way, I'm running Android 2.3.7 with CM7 final, and also this bug does not occur on the stable or beta versions of Firefox.
I also have seen these issues, however, it is not limited to black squares.

Unfortunately, I have not been able to consistently reproduce this bug. The best I've been able to do so far is go to https://en.m.wikipedia.org/wiki/Mozilla and scroll the page. Sometimes the page will corrupt and sometimes it will not.

I first started noticing these issues on Friday, 8/31, though my build may have been a few days old at that point (I don't think it was though).

Tested on Galaxy Nexus, Android 4.0.4.
Status: UNCONFIRMED → NEW
status-firefox18: --- → affected
Component: General → Graphics, Panning and Zooming
Ever confirmed: true
Keywords: regression
Summary: Black Squares on Firefox for Android Nightly → Graphical corruption on page content
Created attachment 657976 [details]
Miscellaneous graphical corruption
(Reporter)

Comment 5

7 years ago
Same bug here. Very annoying. I also get the multicolored corrupted pixels.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 787732
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.