Crash on exit or closing mail window.

VERIFIED INVALID

Status

VERIFIED INVALID
18 years ago
10 years ago

People

(Reporter: scottputterman, Assigned: gordon)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using 2001050212 (Win 2000 for me, according to Talkback both Stephen and I
crashed on exit or closing the mail window with the following stack:

ntdll.dll + 0x1b4d (0x77f81b4d) 
nsCacheEntryDescriptor::Close
nsCacheEntryDescriptor::~nsCacheEntryDescriptor
nsCacheEntryDescriptor::`scalar deleting destructor' 
nsCacheEntryDescriptor::Release
nsCOMPtr_base::~nsCOMPtr_base 
nsMsgMailNewsUrl::~nsMsgMailNewsUrl 
nsImapUrl::`scalar deleting destructor' 
nsImapUrl::Release
nsCOMPtr_base::~nsCOMPtr_base 
nsCacheEntry::~nsCacheEntry 
nsMemoryCacheDevice::EvictEntriesIfNecessary 
nsMemoryCacheDevice::DeactivateEntry 
nsCacheService::DeactivateEntry 
nsCacheService::DeactivateAndClearEntry 
PL_DHashTableEnumerate
nsCacheService::ClearActiveEntries 
nsCacheService::Shutdown 
nsCacheService::Observe  
nsObserverService::Notify 
NS_ShutdownXPCOM

Comment 1

18 years ago
over to gordon. Must be related to the delayed eviction check in he made
yesterday to fix the PR_Lock problem. =(

I don't see this on my debug build with his patch though.
Assignee: mscott → gordon
(Reporter)

Comment 2

18 years ago
These were from the 5/2 build so it may have been fixed yesterday.  It happened
to me once but not the other times I exited.
Yes, same here.  I only saw this once, (and I couldn't reproduce, therefore I
didn't file a bug).
(Assignee)

Comment 4

18 years ago
Looking at the stack trace, it doesn't look like this build had my fix in it, 
which got checked into the trunk around 7ish.  I think it should be safe to mark 
this as INVALID.  Please reopen if anyone sees this again.  Thanks.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
I havent' seen this recently on all the latest builds.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.