Multilingualization of Bugzilla 3.0

RESOLVED WORKSFORME

Status

()

Bugzilla
Bugzilla-General
P3
enhancement
RESOLVED WORKSFORME
17 years ago
12 years ago

People

(Reporter: Koike Kazuhiko, Assigned: Nobody's working on this, feel free to take it)

Tracking

Details

(Reporter)

Description

17 years ago
Bugzilla 2.x has many hardcoded strings in it.

To separate them out makes l18n easier.
i intend to do that
Status: NEW → ASSIGNED
(Reporter)

Comment 2

17 years ago
I hope Bugzilla 3.0 has a multilingual user interface and can accept
bug reports in many languages. If Japanese user visits Bugzilla.org,
it should show Japanese page by contents negotiation, and Bugzilla.org
should accept bug reports in Japanese.

Japanese Mozilla community has their own Bugzilla system from last
year, because MySQL can't handle Japanese code. We accept bug reports
in Japanese and report them to Bugzilla.org in English.

Bugzilla-jp
http://bugzilla.mozilla.gr.jp/
Bugzilla can be multilingual, but that won't make people who only understand
English be able to magically understand the Japanese bug reports. :-(
(Reporter)

Comment 4

17 years ago
Yes, somebody have to translate non-English report into English.

I hope Bugzilla 3.0 works as the following:

(1) Japanese user reports a bug for Japanese component, for example 
[Ja]-[Browser]-[HTML Form].

(2) QA contact for Japanese component translates it into English
component, [En]-[Browser]-[HTML Form].

(3) If the bug in [En] is marked as fixed, the bug in [Ja] should be
marked as fixed automatically.

How about this: when you add a comment, you can categorise it, and one of the
categories would be "Japanese" and another would be "Translation" and then the
default view for English users would be to hide the "Japanese" comments. This
would mean there is no need to enter two bugs all the time, which would just 
make the japanese users seem to have high duplicate ratios.
Target Milestone: --- → Bugzilla 3.0
(Reporter)

Comment 6

17 years ago
Nice idea. But I'm afraid it won't work well. If several Japanese users discuss
about a bug, that discussion should be translated into English. If there is
one bug, who is responsible for translating into English isn't clear.

I'm adding Adrian. Do you have any idea?
Well... who is responsible for translating now?
(Reporter)

Comment 8

17 years ago
I'm a component owner for all component of "Mozilla" product in Bugzilla-jp.
So I'm responsible in almost all case.

For i18n of Bugzilla, we have:
http://bugzilla.mozilla.gr.jp/show_bug.cgi?id=879
I think maybe I'm not explaining what I mean very well.

Here is the scenario as I see it now:
   A Japanese speaker files bug 1.
   A translator files bug 2 by translating bug 1.
   Bug 1 is marked as a duplicate of bug 2.

Here is the scenario I would like to see:
   A Japanese speaker files bug 1, with his comment tagged as Japanese.
   A translator adds another comment to the bug, tagged as English.

There is no extra work, since the same number of comments need to be translated.
If people wish to comment in the bug, they can do so in their language, and the
translator can then query for comments that need translating. In addition, it 
keeps discussion of a single bug in one place, and doesn't skew the statistics
for non-English bug reporters.

I want to make this as easy as possible for you, so please explain what it is
about the system I propose that makes it be less good than the alternative! I
hope I'm explaining it well. Give me a shout if I'm mumbling! :-)
(Reporter)

Comment 10

17 years ago
I'm changing summary. We are talking about multilingualization here.
Summary: Bugzilla 3.0 needs i18n → Multilingualization of Bugzilla 3.0
(Reporter)

Comment 11

17 years ago
Adding momoi-san.
The Bugzilla 3 component is going away.  We're going to depend on the Milestones 
for this.  At the time this component was created, we didn't have milestones for 
Bugzilla.
Component: Bugzilla 3 → Bugzilla
Severity: normal → enhancement
Priority: -- → P3
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: Bugzilla 2.10 → 2.10

Updated

16 years ago
Depends on: 137960
Bailing on Bugzilla 3.0 due to too many other commitments.
Assignee: ian → nobody
Status: ASSIGNED → NEW

Updated

13 years ago
Assignee: nobody → nobody

Comment 14

12 years ago
It seems this bug should be split into two bugs:

1. separate strings from code for i18n.
2. multilanguage reporting and translation scheme.

Updated

12 years ago
QA Contact: mattyt-bugzilla → default-qa

Comment 15

12 years ago
Yeah, I think we're pretty good on i18n nowadays.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Target Milestone: Bugzilla 3.0 → ---
You need to log in before you can comment on or make changes to this bug.