The change event is not firing when bound to a input text field in FF 15

RESOLVED WORKSFORME

Status

()

Core
DOM: Events
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: rchicangana, Unassigned)

Tracking

14 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

In my web application in all forms use the onchange event on text input, this evneto version soared to 14.01 and worked correctly in version 15 there are cases where it no longer works, ie does not fire


Actual results:

not fire the onChange event when any function that changes its content dynamically, eg

<input type="text" id="textfield1" onchange="alert('hi world')">

operates correctly

but

If we apply the same field some function eg to put a mask when a number using the script (http://javascript.espaciolatino.com/scripts/editinputnume.htm) and onChange event does not fire


Expected results:

should trigger the event, as in previous versions of Firefox prior to 15.0 and as in all other browsers
(Reporter)

Updated

6 years ago
Severity: normal → critical
Component: Untriaged → DOM: Events
Product: Firefox → Core
Dupe of Bug 787102?

Updated

6 years ago
Severity: critical → normal
rchicangana@synersis.net, can you verify this Issue being fixed by testing against a Nightly?

http://nightly.mozilla.org/
(Reporter)

Comment 3

6 years ago
 XtC4UaLL [:xtc4uall], Verified, the issue is resolved in version 18.01a thanks friends
Ok, thanks for that. You also are free to check Beta/Aurora Builds regularly (as Trunk Fixes might ported over) to to get a Sense for the Timeline your Web Application will work again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.