Last Comment Bug 788172 - Proxy is not a function (typeof Proxy should be 'function')
: Proxy is not a function (typeof Proxy should be 'function')
Status: RESOLVED FIXED
[js:p2]
: dev-doc-complete, site-compat
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: 18 Branch
: All All
: -- normal (vote)
: mozilla25
Assigned To: Jason Orendorff [:jorendorff]
:
Mentors:
Depends on: 899399 892714
Blocks: es6 703537
  Show dependency treegraph
 
Reported: 2012-09-04 07:57 PDT by David Bruant
Modified: 2013-08-19 13:42 PDT (History)
12 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (15.18 KB, patch)
2012-11-26 06:20 PST, Jason Orendorff [:jorendorff]
ejpbruel: review+
Details | Diff | Review
rebased patch (15.33 KB, patch)
2013-06-03 08:00 PDT, Sankha Narayan Guria [:sankha]
ejpbruel: review+
Details | Diff | Review
rebased again (14.42 KB, patch)
2013-07-02 09:28 PDT, Sankha Narayan Guria [:sankha]
no flags Details | Diff | Review

Description David Bruant 2012-09-04 07:57:50 PDT
Additionally to typeof, "Proxy" should be callable and do the same thing as "new Proxy"
Comment 1 Jason Orendorff [:jorendorff] 2012-11-26 06:20:14 PST
Created attachment 685134 [details] [diff] [review]
v1

The spec is vague at present but this seems clearly what's intended.

With this patch, Proxy(...) behaves exactly like new Proxy(...).

I thought it should get at least a little test coverage, so in addition to the obvious tests I also did s/new Proxy/Proxy/g on jit-test/tests/proxytest*1.js, arbitrarily switching a few existing tests to the new syntax.
Comment 2 Jason Orendorff [:jorendorff] 2013-01-13 05:43:20 PST
Review ping! (I know, king of hypocrites here)
Comment 3 Eddy Bruel [:ejpbruel] 2013-01-13 18:48:50 PST
Comment on attachment 685134 [details] [diff] [review]
v1

Review of attachment 685134 [details] [diff] [review]:
-----------------------------------------------------------------

Patch looks good Jason! No comments.

I do have a question though: what exactly are cached protos?
Comment 4 Tom Schuster [:evilpie] 2013-05-01 12:03:58 PDT
We should get this rebased and landed.
Comment 5 Sankha Narayan Guria [:sankha] 2013-06-03 08:00:19 PDT
Created attachment 757415 [details] [diff] [review]
rebased patch

I have rebased the old patch. Should be good to land now!
Comment 6 Eddy Bruel [:ejpbruel] 2013-07-02 08:16:18 PDT
Comment on attachment 757415 [details] [diff] [review]
rebased patch

Review of attachment 757415 [details] [diff] [review]:
-----------------------------------------------------------------

Looks like this patch was rebased, but never landed, probably because it was flagged for review. In general, I don't think its necessary to review a patch again if its a simple rebase.
Comment 7 Sankha Narayan Guria [:sankha] 2013-07-02 09:28:43 PDT
Created attachment 770225 [details] [diff] [review]
rebased again

Rebased the patch once again.
Comment 8 Ryan VanderMeulen [:RyanVM] 2013-07-02 12:53:00 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/09dcdc2b2120
Comment 9 Ryan VanderMeulen [:RyanVM] 2013-07-03 11:36:15 PDT
https://hg.mozilla.org/mozilla-central/rev/09dcdc2b2120

Note You need to log in before you can comment on or make changes to this bug.