Closed Bug 788222 Opened 8 years ago Closed 8 years ago

Rename PNK_RB and friends

Categories

(Core :: JavaScript Engine, defect)

Other Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla18

People

(Reporter: jorendorff, Assigned: jorendorff)

Details

Attachments

(1 file)

PNK_LB -> PNK_ELEM
PNK_LP -> PNK_CALL
PNK_RB -> PNK_ARRAY
PNK_RC -> PNK_OBJECT
PNK_RP -> (gone)
Attached patch v1Splinter Review
Assignee: general → jorendorff
Attachment #658167 - Flags: review?(jwalden+bmo)
Comment on attachment 658167 [details] [diff] [review]
v1

Review of attachment 658167 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/frontend/Parser.cpp
@@ +4068,5 @@
>       * The four options here are:
>       * - PNK_VAR:   We're parsing var declarations.
>       * - PNK_CONST: We're parsing const declarations.
>       * - PNK_LET:   We are parsing a let declaration.
> +     * - PNK_CALL:  We are parsing the head of a let block.

Egad.  PNK_LP at least didn't give the wrong impression here, because the name was so crazy.  Now, this is just insane.  Could you file a followup to change at least this one case to not use PNK_LP somehow?  PNK_LETBLOCK seems like what should really happen here.
Attachment #658167 - Flags: review?(jwalden+bmo) → review+
Er, good point. Sorry about that.
https://hg.mozilla.org/mozilla-central/rev/c2e5feedaa8f
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
You need to log in before you can comment on or make changes to this bug.