Additional file extensions being added to downloads when directly opening them from Firefox.

RESOLVED INVALID

Status

()

Toolkit
Downloads API
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: skoobiedu, Unassigned)

Tracking

15 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 658195 [details]
File download window with "Open with" selected.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120824154833

Steps to reproduce:

1. Go to http://developer.android.com/tools/sdk/ndk/index.html
2. Click the package link for Mac OS X or Linux (a .tar.bz2 file)
3. Choose to "Open with ..." (I use 7-zip)


Actual results:

The file is downloaded with an additional extension appended to the end (.tar).


Expected results:

No additional extension should have been appended.
(Reporter)

Comment 1

6 years ago
Created attachment 658196 [details]
Downloads window (Download Manager) showing file with appended extension.
(Reporter)

Updated

6 years ago
Attachment #658196 - Attachment description: Downloads Window (Download Manager) → Downloads window (Download Manager) showing file with appended extension.
(Reporter)

Updated

6 years ago
Attachment #658195 - Attachment description: File Download Window → File download window with "Open with" selected.
(Reporter)

Comment 2

6 years ago
This also happens with .tgz (becomes .tgz.tar) files.

I don't encounter this issue when I save the file first.

I checked my registry settings to see if maybe it had something to do with file associations, but .bz2 and .tgz files have the correct file types and associations.

When I googled this, most of the results had to do with Firefox .tar.bz2 downloads. The only result that came close was a bug report for Google Chrome sanitizing extensions, which most users hate (me included).
(Reporter)

Comment 3

6 years ago
This may have more to do with the Android web site because the following link works as expected:

http://download.mozilla.org/?product=firefox-15.0&os=linux&lang=en-US
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.