If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

DeviceStorageFile::IsType misclassifies audio files on otoro

RESOLVED FIXED

Status

Firefox OS
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: dhylands, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [WebAPI:P0])

(Reporter)

Description

5 years ago
I tried to run the Music player app on my otoro and even though I have songs in my Music folder, the Music player showed no songs. Looking in logcat, I saw:

IsType of /sdcard/Music/treasure_island_01-02_stevenson.ogg is video/ogg (took: 0ms)
IsType of /sdcard/Music/b2g.ogg is video/ogg (took: 0ms)
IsType of /sdcard/Music/Salt_Creek.ogg is video/ogg (took: 0ms)
IsType of /sdcard/Music/jonobacon-freesoftwaresong2.ogg is video/ogg (took: 0ms)
GetTypeFromFile failed for /sdcard/Music/01_-_Love Who You LoveRascal Flatts.mp3 (took: 0ms)

Using the linux file command showed:

01_-_Love Who You LoveRascal Flatts.mp3: Audio file with ID3 version 2.3.0, contains: MPEG ADTS, layer III, v1, 128 kbps, 44.1 kHz, JntStereo
b2g.ogg:                                 Ogg data, Vorbis audio, stereo, 44100 Hz, ~192000 bps, created by: Xiph.Org libVorbis I
jonobacon-freesoftwaresong2.ogg:         Ogg data, Vorbis audio, stereo, 44100 Hz, ~160000 bps, created by: Xiph.Org libVorbis I
Salt_Creek.ogg:                          Ogg data, Vorbis audio, stereo, 44100 Hz, ~112000 bps, created by: Xiph.Org libVorbis I
treasure_island_01-02_stevenson.ogg:     Ogg data, Vorbis audio, mono, 44100 Hz, ~80000 bps, created by: Xiph.Org libVorbis I (1.1.0 RC1)

Comment 1

5 years ago
probably fixed by 786922	.
I saw this, too, and think it should block.  Bug 786922 is already a Basecamp blocker.
blocking-basecamp: ? → +

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 786922
Resolution: DUPLICATE → FIXED
Whiteboard: [WebAPI:P0]
You need to log in before you can comment on or make changes to this bug.