Full screen elements do not scroll

RESOLVED DUPLICATE of bug 779286

Status

()

Core
General
RESOLVED DUPLICATE of bug 779286
6 years ago
6 years ago

People

(Reporter: Brad Dougherty, Unassigned)

Tracking

15 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_1) AppleWebKit/536.25 (KHTML, like Gecko) Version/6.0 Safari/536.25

Steps to reproduce:

Called mozRequestFullscreen() on document.documentElement. (on this page: http://brad.is/coding/BigScreen/)


Actual results:

The page goes into full screen but does not scroll


Expected results:

The page should be able to scroll. The following styles make it so that you can scroll the page:

html:-moz-full-screen {
    overflow: auto;
}
html:-moz-full-screen body {
    width: 100%;
    height: 100%;
    overflow: auto;
}

Another issue arises from this hack. If you scroll down while in full screen, that position will not be maintained when you exit and you'll be returned to the top of the page.
(Reporter)

Comment 1

6 years ago
I should also note that this happens on Windows and OS X. Additionally, Chrome and Safari handle this properly.

Updated

6 years ago
Component: Untriaged → General
Product: Firefox → Core

Comment 2

6 years ago
Brad, I don't see a button on http://brad.is/coding/BigScreen/ that puts the whole page in fullscreen. When getting the image and video on the page in fullscreen, they don't scroll on other browsers either.

Can you please give the link to a page where this issue reproduces?
Per current spec, the page as authored should not scroll.  But a spec change is being considered....
(Reporter)

Comment 4

6 years ago
@ioana - Sorry! Click the title at the top of the page. I made a copy of the page that does not have the css hack applied: http://brad.is/coding/BigScreen/noscroll.html

Comment 5

6 years ago
I have verified this on the Firefox 15 to 18 (Nightly 09/11) and it seems it has already been fixed on Firefox 18.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 779286
You need to log in before you can comment on or make changes to this bug.