Closed Bug 788427 Opened 8 years ago Closed 8 years ago

Crash Report [@ mozalloc_abort | __swrite | libxul.so@0x10d3cf7 | org.mozilla.firefox_beta-1.apk@0xf00633 ]

Categories

(Firefox for Android :: General, defect, critical)

16 Branch
ARM
Android
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 774622

People

(Reporter: paul.feher, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-17869d32-edc3-460c-b35e-26fe22120905 .
============================================================= 
Frame 	Module 	Signature 	Source
0 	libmozalloc.so 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:19
1 	libc.so 	__swrite 	
2 	libxul.so 	libxul.so@0x10d3cf7 	
3 	dalvik-heap (deleted) 	dalvik-heap @0x11f111f 	
4 	org.mozilla.firefox_beta-1.apk 	org.mozilla.firefox_beta-1.apk@0xf00633 	
5 	libxul.so 	XPCJSRuntime::Get 	js/xpconnect/src/xpcprivate.h:645
6 	libxul.so 	XPCCallContext::~XPCCallContext 	js/xpconnect/src/XPCCallContext.cpp:302
7 	libxul.so 	nsXPCWrappedJSClass::DelegatedQueryInterface 	js/xpconnect/src/XPCWrappedJSClass.cpp:745
8 		@0xffffffff 	
9 	libxul.so 	XPCCallContext::~XPCCallContext 	js/xpconnect/src/XPCCallContext.cpp:334
10 	libxul.so 	nsXPCWrappedJSClass::DelegatedQueryInterface 	js/xpconnect/src/XPCWrappedJSClass.cpp:745
11 		@0x484f2d7e 	
12 	libmozglue.so 	malloc_mutex_unlock 	memory/mozjemalloc/jemalloc.c:1629
13 	libmozglue.so 	arena_malloc 	memory/mozjemalloc/jemalloc.c:4129
14 	libmozglue.so 	imalloc 	memory/mozjemalloc/jemalloc.c:4209
15 	libmozglue.so 	__wrap_realloc 	memory/mozjemalloc/jemalloc.c:6527
16 		@0x3e 	
17 	libdvm.so 	dexDataMapAlloc 	
18 	libmozglue.so 	imalloc 	memory/mozjemalloc/jemalloc.c:4209
19 		@0x8052100e 	
20 	libmozglue.so 	std::__node_alloc_impl::_M_allocate 	_threads.h:349
21 	libmozglue.so 	std::__node_alloc::_M_allocate 	allocators.cpp:743
22 	libxul.so 	std::__node_alloc::allocate 	_alloc.h:158
23 	libxul.so 	std::priv::_STLP_alloc_proxy<unsigned int, IPC::Message, std::allocator<IPC::Mes 	_alloc.h:307
24 		@0x3 	
25 	libdvm.so 	dexDataMapAlloc 	
26 	libxul.so 	mozilla::ipc::RPCChannel::DebugAbort 	ipc/glue/RPCChannel.cpp:656
27 	libxul.so 	mozilla::ipc::RPCChannel::~RPCChannel 	ipc/glue/RPCChannel.cpp:80
28 	libxul.so 	mozilla::layers::PCompositorParent::~PCompositorParent 	obj-firefox/ipc/ipdl/PCompositorParent.cpp:88
29 	libxul.so 	mozilla::layers::CompositorParent::~CompositorParent 	gfx/layers/ipc/CompositorParent.cpp:106
30 	libxul.so 	mozilla::layers::CompositorParent::~CompositorParent 	gfx/layers/ipc/CompositorParent.cpp:106
31 	libxul.so 	mozilla::layers::CompositorParent::Release 	CompositorParent.h:58
32 	libxul.so 	RunnableFunction<void , Tuple2<nsRefPtr<mozilla::layers::CompositorParent>, nsRe 	nsAutoPtr.h:874
33 	libxul.so 	RunnableFunction<void , Tuple2<nsRefPtr<mozilla::layers::CompositorParent>, nsRe 	ipc/chromium/src/base/task.h:411
34 	libxul.so 	MessageLoop::RunTask 	ipc/chromium/src/base/message_loop.cc:327
35 	libxul.so 	MessageLoop::DeferOrRunPendingTask 	ipc/chromium/src/base/message_loop.cc:334
36 	libxul.so 	MessageLoop::DoWork 	ipc/chromium/src/base/message_loop.cc:434
37 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:86
38 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
39 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
40 	libxul.so 	nsBaseAppShell::Run 	widget/xpwidgets/nsBaseAppShell.cpp:163
41 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:257
42 	libxul.so 	XREMain::XRE_mainRun 	toolkit/xre/nsAppRunner.cpp:3794
43 	libxul.so 	XREMain::XRE_main 	toolkit/xre/nsAppRunner.cpp:3871
44 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3947
45 	libxul.so 	GeckoStart 	toolkit/xre/nsAndroidStartup.cpp:73
46 	libmozglue.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	mozglue/android/APKOpen.cpp:983
47 	libdvm.so 	dvmPlatformInvoke 	
48 	libdvm.so 	dvmCallJNIMethod_general 	
49 	libdvm.so 	dvmResolveNativeMethod 	
50 	libdvm.so 	dvmAsmSisterStart 	
51 	libdvm.so 	dvmMterpStd 	
52 	libdvm.so 	dvmInterpret 	
53 	libdvm.so 	dvmCallMethodV 	
54 	libdvm.so 	dvmCallMethod 	
55 	libdvm.so 	dvmDetachCurrentThread 	
56 	libc.so 	__thread_entry 	
57 	libc.so 	pthread_create 	

Firefox Mobile 16 beta 2 build 1
Device: HTC Desire Z (2.3.3)

Possible STR:
1. Quit fennec
Same as bug 774670, bug 776496 and bug 782264 you filed.
Check the abort message and see if there's already a bug with it before filing a bug.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 774622
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.