Closed Bug 788475 Opened 7 years ago Closed 7 years ago

"Blank Page" icon from Linux system icon theme is inappropriate for use as "no favicon"

Categories

(Firefox :: Theme, defect)

17 Branch
All
Linux
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: from_bugzilla2, Unassigned)

Details

When I was upgraded to Aurora 17, I immediately noticed the change from a dotted/dashed square to the system "blank page" icon for pages without favicons. While I appreciate the effort, proper consideration for the final effect should be taken in a situation like this.

Generally-speaking, as a side-effect of being intended for use in file manager listings and toolbars to connote "this is an empty file" (item) or "create a new file" (verb), blank page icons very much give a feel of "being something".

In a tab without a favicon, it is much more desirable for an icon not provided by the site to intuitively present itself as a "lack of something"... a goal which the dotted/dashed square icon attains admirably by connoting a blank space where the website designer is supposed to glue an icon.

In other words, it's an icon intended for about:blank but not for other pages that actually have content.

Conveying a sense that the icon is "something" is also undesirable because, on an intuitive level, it makes it more effort to recognize and ignore the icons as not indicative of a tab's contents. (Especially in app tabs such as the four I have containing suggested study schedules for courses)

This effect is further magnified by the fact that, since they are typically designed to appear in file manager views first and foremost, the blank page icons in themes like Elementary (Lubuntu Linux default) are not colour-coordinated to feel natural when placed on the system widget background colour. (My tabs are coloured in a warm grey, but the icon is blue-tinted)

I think these reasons are more than enough to justify reverting to the old icon, possibly in concert with lookup via an application-specific addition to the system icon search path so it can be overridden if it doesn't provide adequate contrast with the system theme. (Either that, or you could colour it at runtime using the system foreground colour)

Using application-specific adjustments to the GTK+ icon-resolution functions to make application-specific icons themable is explained here:
https://live.gnome.org/ThemableAppSpecificIcons
Not sure what version you updated from, the dashed border icon landed over a year ago (bug 648668) and has been in use since firefox 9 (released 9 months ago). And the change was to make it easier to identify pages that has icon from those that doesn't.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 702730
I upgraded from Aurora 16 to Aurora 17 and this is not a duplicate. I'm saying the opposite (bring back the dotted square).

I'd really appreciate if you'd read more carefully before marking a bug resolved.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Are you running aurora from mozilla server or through fedoras repo? Cause both aurora and nightly still have the dotted square here.

Aurora build id: 20120905042008
Nightly build id: 20120905030555
(In reply to Stephan Sokolow from comment #0)

> In a tab without a favicon, it is much more desirable for an icon not
> provided by the site to intuitively present itself as a "lack of
> something"... a goal which the dotted/dashed square icon attains admirably
> by connoting a blank space where the website designer is supposed to glue an
> icon.

The Web site designer *is not supposed to put an icon*. This is just a possibility, and a poorly standardized one (.ico ...).

The plain old document icon might not be the ideal one, but it is much better than than the new horrible dotted empty square. The problem with the dotted empty square is that it attracts the eye of the user and make her/him think something is missing. But nothing is missing. A Web page without favicon is perfectly fine.
(In reply to Cork from comment #3)
> Are you running aurora from mozilla server or through fedoras repo? Cause
> both aurora and nightly still have the dotted square here.
> 
> Aurora build id: 20120905042008
> Nightly build id: 20120905030555

Give me an hour or two to finish my morning routine and I'll check.

(In reply to Nicolas Barbulesco from comment #4)
> The Web site designer *is not supposed to put an icon*. This is just a
> possibility, and a poorly standardized one (.ico ...).
> 
> The plain old document icon might not be the ideal one, but it is much
> better than than the new horrible dotted empty square. The problem with the
> dotted empty square is that it attracts the eye of the user and make her/him
> think something is missing. But nothing is missing. A Web page without
> favicon is perfectly fine.

I beg to disagree on both counts.

First, given app tabs and how many users (both via Firefox hacks and in non-Firefox browsers) have tabs collapsed down to only icons, it's foolish at best to not have a favicon. Regardless of its de jure standardization status, favicons have become a de facto standard in the expectations of users and, of the people I've talked to who pay them enough attention to have an opinion, the general consensus is that a site without a favicon feels unprofessional, lazy, and dated. (Not to mention harder to acquire at a glance from among a sea of tabs)

Second, I'd argue that it's better to imply something is missing in order to make it intuitively clear that the icon was not provided by the site than to provide an icon that is intuitively "something" at the cost of it feeling site-provided. (In part, because like everything else site-provided, the icon color scheme doesn't smoothly fit in with the system color scheme.)

I'm not sure how others feel about this specific point, but I also find it takes more time and mental effort to pick out the "no favicon" icon from among a large set of tabs if it is a blank page, because it blends in among the other "something" icons.
(In reply to Cork from comment #3)
> Are you running aurora from mozilla server or through fedoras repo? Cause
> both aurora and nightly still have the dotted square here.
> 
> Aurora build id: 20120905042008
> Nightly build id: 20120905030555

Ugh. I've managed to confirm that it's Mozilla at fault and it's not even the packagers who run the Ubuntu Aurora PPA I'm using.

I still get the dotted square when I load up the extension-free profile I use for testing my multi-lingual creations with French Accept-Language headers.

Time to try to bisect my way to to an addon to 1-star rate on AMO for stepping outside the bounds of what it says it'll do.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → INVALID
Correction: managed to confirm that it's *not* Mozilla at fault...
(In reply to Stephan Sokolow from comment #5)

> I'm not sure how others feel about this specific point, but I also find it
> takes more time and mental effort to pick out the "no favicon" icon from
> among a large set of tabs if it is a blank page, because it blends in among
> the other "something" icons.

There is one thing on which we may agree : it would be better to have two different icons for the blank tab and for the no-favicon page. I propose to have the plain old blank document (empty document) for the blank tab, and to have this document icon, but with lines (written document), for the no-favicon page.
(In reply to Nicolas Barbulesco from comment #8)
> (In reply to Stephan Sokolow from comment #5)
> 
> > I'm not sure how others feel about this specific point, but I also find it
> > takes more time and mental effort to pick out the "no favicon" icon from
> > among a large set of tabs if it is a blank page, because it blends in among
> > the other "something" icons.
> 
> There is one thing on which we may agree : it would be better to have two
> different icons for the blank tab and for the no-favicon page. I propose to
> have the plain old blank document (empty document) for the blank tab, and to
> have this document icon, but with lines (written document), for the
> no-favicon page.

I can definitely agree on different icons for about:blank and "no favicon" and what you suggest would definitely help. I'm just not sure it's possible to get the full effect I want with iconography based on a page.
You need to log in before you can comment on or make changes to this bug.