If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

IMAP folders containing subfolders have different fonts

RESOLVED INVALID

Status

Thunderbird
Folder and Message Lists
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: purlaba25, Unassigned)

Tracking

15 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 658549 [details]
Screenshot that shows the difference

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120824154833

Steps to reproduce:

During the last years I have created some IMAP folders. Some using Thunderbird, and some others using a web-interface. 


Actual results:

Unfortunately Thunderbird displays folders that contain subfolders differently (some are italic and others are not).


Expected results:

Since I don't know of any configuration differences between the folders, I think the folders names should use the same font. This doesn't prevent me from managing my mails, but it is annoying.

Comment 1

5 years ago
Gray/italic folder names indicate that the folder has the \Noselect flag set in IMAP, meaning that it can contain subfolders, but not messages.
(Reporter)

Comment 2

5 years ago
But as my screenshot shows, both folders are folders containing subfolders (it is not possible to move messages in either one). The difference is, that if I try to move a message into the italic-folder (by drag and drop) it is not possible to drop it. It is different with the bold folder: I can drop a message into this folder but then the server returns an error and the message is moved into its initial folder again.

So is this a configuration issue on the server then?

Comment 3

5 years ago
(In reply to purlaba25 from comment #2)
> The difference is, that if I try to move a message into the italic-folder (by drag and drop) it is not possible to drop it.

This is what I meant. The italic folder is a \Noselect folder, which cannot contain messages, only subfolders.

> So is this a configuration issue on the server then?

Yes.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.