text-align interpreted incompletely

VERIFIED DUPLICATE of bug 49274

Status

()

Core
CSS Parsing and Computation
VERIFIED DUPLICATE of bug 49274
17 years ago
16 years ago

People

(Reporter: Stefan Moebius, Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Goto the URL above.

Expected:
both the text line and the table are centered horizontaly
Actual:
only the text line is centered

Browser:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9+) Gecko/20010503

Both IE5.5 and NS4.77 center both items. (Although NS has problems with more
complex pages ;-)
If mozilla's behavior follows the specs and this is not a bug, then what is the
correct way to center the table (using css)? (Sorry for the spam in that case)
The correct way is { margin-left: auto; margin-right: auto } on the table.

text-align only centers inline children, per the spec.

*** This bug has been marked as a duplicate of 49274 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.