If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Upstream uses invalid C++ which newer compilers cannot deal with

RESOLVED DUPLICATE of bug 854389

Status

Firefox OS
GonkIntegration
P5
enhancement
RESOLVED DUPLICATE of bug 854389
5 years ago
4 years ago

People

(Reporter: hub, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 658647 [details]
include unistd.h

Emulator arm for b2g failed to build on Fedora 17. Because it hasn't been test on a recent libc.

Attaching patch to sdk/emulator sub tree.
(Reporter)

Comment 1

5 years ago
Created attachment 658685 [details] [diff] [review]
include unistd.h

Looks like I couldn't manage to create the patch the first time. Here it is this time.
Attachment #658647 - Attachment is obsolete: true
(Reporter)

Comment 2

5 years ago
And the error I get is a missing getopt() and associated symbols.
Duplicate of this bug: 808551
Current sdk revision is two commits behind aosp/ics-plus-aosp and we hard-coded it in the manifest. https://github.com/mozilla-b2g/android-sdk is long deprecated after switching to B2G-Gingerbread to ICS. We'll need works in both manifests/ and sdk/ to land this. Ask mwu for opinions.
Flags: needinfo?(mwu)
Current sdk revision is two commits behind aosp/ics-plus-aosp and we hard-coded it in the manifest. https://github.com/mozilla-b2g/android-sdk is long deprecated after switching to B2G-Gingerbread to ICS. We'll need works in both manifests/ and sdk/ to land this. Ask mwu for opinions.

Comment 6

5 years ago
Host GCCs newer than 4.6.3 are not supported on ICS based B2G.
Flags: needinfo?(mwu)
Since the build instructions on MDN allow proper building on Fedora 17/18 (with the help of a prebuilt GCC 4.4.7) I think we should close this. See:

https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS/Firefox_OS_build_prerequisites?redirectlocale=en-US&redirectslug=Firefox_OS%2FFirefox_OS_build_prerequisites#64_bit_install_examples.3A
(Reporter)

Comment 8

5 years ago
We should close it when the C++ code is C++ conformant. I know it might take a while with upstream, but the problem is real. It is not just "fancy compilers".
(In reply to Hubert Figuiere [:hub] from comment #8)
> We should close it when the C++ code is C++ conformant. I know it might take
> a while with upstream, but the problem is real. It is not just "fancy
> compilers".

That's valid and correct, but the reality of the situation is that we don't control the code that's broken.  Renaming this bug to match what is keeping it open.

I suspect that the resolution here will be that nothing changes until we're based on JB Gonk.
Severity: normal → enhancement
Priority: -- → P5
Summary: Emulator build fail on Fedora 17 → Upstream uses invalid C++ which newer compilers cannot deal with
(Reporter)

Comment 10

4 years ago
(In reply to John Ford [:jhford] -- please use 'needinfo?' instead of a CC from comment #9)
> (In reply to Hubert Figuiere [:hub] from comment #8)
> > We should close it when the C++ code is C++ conformant. I know it might take
> > a while with upstream, but the problem is real. It is not just "fancy
> > compilers".
> 
> That's valid and correct, but the reality of the situation is that we don't
> control the code that's broken.  Renaming this bug to match what is keeping
> it open.
> 
> I suspect that the resolution here will be that nothing changes until we're
> based on JB Gonk.

I actually have patches in bug 854389 waiting for a r? that actually solve the problem. yes we can address them.

Marking as dupe.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 854389
You need to log in before you can comment on or make changes to this bug.