BACK/FORWARD buttons vanish after theme install. Cannot restore even after uninstall/reinstall of mozilla.

RESOLVED FIXED

Status

Core Graveyard
Skinability
RESOLVED FIXED
17 years ago
6 years ago

People

(Reporter: manojd, Unassigned)

Tracking

({helpwanted})

Trunk
x86
Windows 2000
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.8.1) Gecko/20010323
BuildID:    2001032319

I just installed Mozilla/8.0.1 after picking it up from "mozilla.org". While
playing around with UI, I decided to install the theme "orbit" from Netscape
Theme Park ("http://www.netscape.com/themes/")
["javascript:installTheme('orbit.jar', 'orbit/1.0');"]. After installing it,
LastPage/NextPage buttons vanish from my toolbar!

I try switching the theme back to classic. No good. I install Mozilla, reboot my
Windows, then install it again; no good. I just can not get these buttons back!

Reproducible: Always
Steps to Reproduce: See Description above.
Actual Results:  See Description above.

Comment 1

17 years ago
Themes in the Netscape Theme Park do not include changes made to the xul just
before 0.8.1.

Are you saying the buttons don't come back when you switch back to the Classic
included with 0.8.1?

Comment 2

17 years ago
not a blocker.
Severity: blocker → normal

Comment 3

17 years ago
From email from Manoj:

>There is NO WAY I can get those buttons back. Forget trying to switch theme.
I even tried uninstall of Mozilla; then m/c reboot; then reinstall. There is
nothing I can do to get them back. Uninstall faithfully cleans install dir
as well as registry settings; Mozilla is keeping some state elsewhere in the
system.

>I don't know how you can say it's not a blocker. I mean - the browser is
unusable without these two arrow buttons!

>Manoj Dhooria
>Geometric Software

Comment 4

17 years ago
Try wiping out the contents of the chrome/ directory in your Mozilla user
directory. It sounds like something there is pointing Mozilla to old themes.  We
used to have to do this all the time in order to get Mozilla to even start if we
were using third-party themes.  (Versioning was implemented recently so that's
no longer a problem.)

Comment 5

17 years ago
I suppose this is a skinability problem. Shouldn't be the component changed to
Skiability?
(Reporter)

Comment 6

17 years ago
Jason/4may2001 - "Try wiping out the contents of ...": I *uninstalled* Mozilla - 
 the entire directory containing Mozilla gone - including the whole user 
directory. Then reinstalled in an empty directory. Nor is this state kept in 
Windows registry in an obvious place. And this state persists even after Windows 
reboot. I did reinstall after Windows reboot too.

Comment 7

17 years ago
--> "I can't...even after..."

Delete the file user-skins.rdf in "windows\Application
Data\Mozilla\users50\...\chrome"

:-Dan
(Reporter)

Comment 8

17 years ago
Dan - deleting ApplicationData dir solved the problem. Thank you.

While the problem is solved for me, something obviously needs fixing in Mozilla 
too (though lower priority). At the very least, reinstall should set the chrome 
to default.

Comment 9

17 years ago
For further information on this subject (setting chrome to default and other
chrome stuff) you should follow bug #53670
http://bugzilla.mozilla.org/show_bug.cgi?id=53670

I hope that the problem with vanishing BACK/FORWARD buttons is just a
coincidence of whong things. - Old Netscape Chromes & New XUL in Mozilla. But I
realy like the Netscape Chromes, so I hope I'll be able to use them...(in some
time perhaps)
BTW they work fine in Netscape 6.01 if you would still like to use them. 

:-Dan

Comment 10

17 years ago
confirming, need resolution
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 11

17 years ago
bugs in theme switching belong to the Skinability Component (most of the time).
Component: Browser-General → Skinability

Comment 12

17 years ago
->
Assignee: asa → ben
QA Contact: doronr → pmac
Mass move skinability bugs to nobody@mozilla.org, helpwanted. 
Assignee: ben → nobody
Keywords: helpwanted

Comment 14

16 years ago
Back /forward buttons have vanished and there seems to be no way of moving 
back / forward between pages.  URL Address does not appear in address bar when 
changing pages / accessing a new site

Comment 15

14 years ago
this bug appears too in the FireBird version 0.7 under WIN2000 

Comment 16

14 years ago
this bug appears with exactly the same symptoms in firebird, and now in firefox.
 I have also reproduced this bug in mozilla and netscape, the main theme that
causes it is orbit AFAIK.

Comment 17

14 years ago
this bug appears with exactly the same symptoms in firebird, and now in firefox.
 I have also reproduced this bug in mozilla and netscape, the main theme that
causes it is orbit AFAIK.

Comment 18

14 years ago
I am experiencing the exact same behaviour with Firefox under Linux (Gentoo).

Version Info:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040222 Firefox/0.8

The theme I am using is Px Classic (c 0.4)

Biggest problem is that I haven't found which folder to delete to "reset" the
settings in the home directory (as a temporary fix)

Just noticed that the scroll bars on right side of page also disappeared!

Comment 19

14 years ago
More info and "resolution": 
1- Switch to the default skin. 
2- Restart ALL browser windows. 
 
Definately a skinability issue. I had upgraded from Mozilla Firebird 0.7 to 0.8 
and the skin I used is now no more finctionnal. I had tried going back to the 
default skin and still experienced the button and scrollbar disappearance issue 
even after restarting FireFox... The problem was that I had another instance of 
FireFox running and well....checked the wrong window ;) 

Comment 20

14 years ago
I want Firebird 0.7 back! (I keep having to run IE to turn Work Offline off
properly. It's like a horrible nightmare flashback.) Back to the topic: I
deleted the default theme by accident, so no workaround for me. Either the
default theme should be available on the download page, or the delete button
should be disabled for the default theme.

Comment 21

14 years ago
Sorry about my previous comment: wrong browser. In Firefox this is bug 216602.
Filter on "Nobody_NScomTLD_20080620"
QA Contact: pmac → skinability
(Assignee)

Updated

9 years ago
Product: Core → Core Graveyard

Comment 23

6 years ago
The delete button is disabled for the default theme these days.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.