Image/Media/PluginDocuments should make use of HiDPI mode

RESOLVED DUPLICATE of bug 857089

Status

()

Toolkit
Themes
RESOLVED DUPLICATE of bug 857089
6 years ago
5 years ago

People

(Reporter: Dolske, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
When viewing a [image, video, plugin] directly, these special documents should make use of HiDPI mode when available. EG, on a retina display these would normally be pixel-doubled to appear at the same size (in content, for compatibility). But when viewing them directly, we should show them as crisp as possible.


We should also consider, as part of this work, if we should retain some way of showing small images at a pixel-doubled (or more) size. EG:

Current:

  if (media fits in window w/o scrolling)
    show media
  else
    show scaled-down media w/ click to zoom 1:1

Proposed:
  // using physical pixel sizes
  if (media fits in window w/o scrolling)
    show media scaled-up to window size w/ click to shrink to 1:1
  else
    show media scaled-down to window size w/ click to zoom to 1:1

Alternatively we could consider some kind of "Tools" menu to control this and other modes (eg transparent backgrounds ;).

Comment 1

6 years ago
Does a plugin have a way to 'notify' the browser that it can actually handle rendering in HiDPI mode? 

Cheers,

Jonathan
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 857089
You need to log in before you can comment on or make changes to this bug.