More resistance against accidental starring

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: br.renatosilva, Unassigned)

Tracking

15 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120824154833

Steps to reproduce:

Accidental starring without even noticing.


Actual results:

Potentially private data went to history sort of hidden in unorganized bookmarks, even when using private browsing.


Expected results:

Firefox should ask at least once if the user really want to save the bookmark unorganized. Users that don't care about it would just tell Firefox to not ask again next time, except for private browsing where confirmation should always be displayed when starring.

Updated versions should be sensitive to current users already using stars feature, and maybe, alert people about existence of unorganized bookmarks potentially added by accident, or just allow them to disable stars.

Updated

6 years ago
Severity: normal → enhancement
Component: Untriaged → Bookmarks & History
OS: Windows 7 → All
Hardware: x86 → All
(Reporter)

Comment 1

6 years ago
Created attachment 692487 [details]
Firefox Check Bookmarks 2012.12.14

Attached is a bash script that is going to generate a report to the desktop of current user containing unorganized bookmarks that were found in Firefox. It also reports the ones containing a description, but this can be just ignored for the purpose of this bug. The script can be executed with MinGW MSYS.
(Reporter)

Comment 2

6 years ago
The script requires SQLite command line client.
Thanks for the feedback, unfortunately we want to distract the user as few as possible, that means showing confirmation dialogs is pretty much always the wrong way to fix issues for us.
The Star icon on the other side should be quite visible, plus we have Recently bookmarked search in the menu.
I don't think it's so common case to accidentally bookmark something, especially cause the most common cause may be keyboard shortcuts and those always show a dialog notifying a bookmark has been added.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

6 years ago
It's pretty common in my case, I ended up writing a script that removes them when computer is power off (yes, by hacking into places.sqlite). Since it was marked WONTFIX, here are my two cents at least.

* As explained initially, the confirmation dialog would be displayed only once by default, and I don't see how annoying this would be as opposed to silently storing potentially sensitive data. In other words, a one-time dialog is worth the price, for the sake of good privacy.

* I would assume people usually want to organize their bookmarks by using tags, placing them in appropriate folders, providing descriptions etc. I don't think unorganized bookmarking is more often than that, therefore it just moves the dialog out to a later moment.

* The recently bookmarked item is not an effective way to prevent this, since users need to actively take a look at it, and the star icon does not work well as a notification.

* I think this is one reason that helps users not complaining about this, since if they don't pay attention to the little star and don't actively check their bookmarks out, they don't really have a way to ever noticing this.

* Another suggestion could be switching from single-click to double-click (currently it is double-click that displays the bookmark properties), but I'm afraid of how confusing this change would be for end-users.
You need to log in before you can comment on or make changes to this bug.