Intermittent test_webgl_conformance_test_suite.html | [conformance/textures/gl-teximage.html] Timeout in this test page

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({intermittent-failure})

Trunk
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox18 affected, firefox19 affected)

Details

(Reporter)

Description

6 years ago
Rev4 MacOSX Lion 10.7 mozilla-inbound opt test mochitests-1/5 on 2012-09-05 06:58:57 PDT for push 6afc8e389883

slave: talos-r4-lion-063

https://tbpl.mozilla.org/php/getParsedLog.php?id=14980679&tree=Mozilla-Inbound

{
57373 INFO TEST-INFO | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/textures/gl-teximage.html] (WebGL mochitest) Starting test page
57374 INFO TEST-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/textures/gl-teximage.html] Test passed - getError was expected value: NO_ERROR : Should be no errors from setup.
57375 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | [conformance/textures/gl-teximage.html] Timeout in this test page
}
(Reporter)

Comment 1

6 years ago
Android Tegra 250 mozilla-inbound opt test mochitest-1 on 2012-09-05 17:51:16 PDT for push 72c85979e852

slave: tegra-262

https://tbpl.mozilla.org/php/getParsedLog.php?id=14999107&tree=Mozilla-Inbound
OS: Mac OS X → All
Hardware: x86_64 → All
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Duplicate of this bug: 803597
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Blocks: 810556
Comment hidden (Treeherder Robot)
status-firefox18: --- → affected
status-firefox19: --- → affected
(Reporter)

Comment 38

6 years ago
bjacob, please may you look at this?
(Or if you don't have the cycles, let me know and we can just disable the test on Android).
Flags: needinfo?(bjacob)
It's not that I don't have the cycles --- it's that I have looked into this kind of intermittent WebGL test timeouts on Android before and they can only be explained as an infra issue, most likely the Android slaves don't have enough memory. So, disabling a single page in the WebGL mochitest tends to displace the problem to the next big WebGL test page.

The better compromise, rather than disabling the WebGL mochitest altogether, would be to disable only say 80% of it and keep a smart 20% subset that would be enough to catch most regressions. Let me try to see if I can make such a patch.
Flags: needinfo?(bjacob)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

6 years ago
Keywords: intermittent-failure
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

6 years ago
Whiteboard: [orange]
(Reporter)

Comment 47

6 years ago
Resolving WFM any keyword:intermittent-failure bug where:
* Changed: (is less than or equal to) -3m
* Whiteboard: (contains none of the strings) random disabled marked fuzzy todo fails failing annotated time-bomb
* Whiteboard: (does not contain the string) leave open

There will inevitably be some false positives; for that (and the bugspam) I apologise, but at least this will clear out the open cruft (and thus reduce risk of mis-starring) on TBPL's annotated summary bug suggestions.

Filter on orangewfm.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.