WebSocket Connect Twice in FF15

RESOLVED DUPLICATE of bug 782704

Status

()

RESOLVED DUPLICATE of bug 782704
6 years ago
6 years ago

People

(Reporter: ny_mand, Unassigned)

Tracking

15 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120825192214

Steps to reproduce:

I connect a client to my WebSocket server.


Actual results:

The server gets 2 incoming connections. One containing the handshake header, and one containing nothing. This result in the server not able to communicate with the client. My theory is that the client is listening on the second connection, which is the empty one.

I have tested in FF15 on both Linux Ubuntu 12.04 and Windows Vista.


Expected results:

I obviously should only have got 1 incoming connection from the client, which should contain the handshake header.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Component: Untriaged → Networking: WebSockets
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 782704
You need to log in before you can comment on or make changes to this bug.