bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Download manager ends all active downloads after "Clear all history"

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: t8av, Unassigned)

Tracking

15 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120824154833

Steps to reproduce:

I was downloading files. The Download manager indicated that the downloads are progressing.

While downloading, I used the "Clear recent/all history" tool and chose only to delete the cache.



Actual results:

Firefox hang for about 40 seconds and then was active again, however all the downloads ended prematurely (immediately after Firefox was active again).



Expected results:

Downloads should continue to be active regardless the use of "Clear recent/all history".

Comment 1

6 years ago
Mozilla/5.0 (X11; Linux x86_64; rv:18.0) Gecko/18.0 Firefox/18.0
Downloading http://releases.mozilla.org/pub/mozilla.org/firefox/releases/15.0.1/source/firefox-15.0.1.source.tar.bz2 (80M).

Works for me, except that during the clearing, the Downloads window loses information on the time left to download the file for a moment.

A 2010 report: bug 538798.

Comment 2

6 years ago
Could it be that, because of the 40 seconds hang, the connection timed out?

Comment 3

6 years ago
The hang might be bug 645471.

Comment 4

5 years ago
(In reply to Aleksej [:Aleksej] from comment #1)
> Mozilla/5.0 (X11; Linux x86_64; rv:18.0) Gecko/18.0 Firefox/18.0
> Downloading
> http://releases.mozilla.org/pub/mozilla.org/firefox/releases/15.0.1/source/
> firefox-15.0.1.source.tar.bz2 (80M).
> 
> Works for me, except that during the clearing, the Downloads window loses
> information on the time left to download the file for a moment.
> 
> A 2010 report: bug 538798.

@t8av, if you still see the problem, do you agree with the above comments?
(In reply to Aleksej [:Aleksej] from comment #3)
> The hang might be bug 645471.
Flags: needinfo?(t8av)
(Reporter)

Comment 5

5 years ago
1. According to my experience with Firefox, any slowness or hang might influence the download manager, but this is a random thing. 

2. This bug is relatively simple to test. Just create a significant hang/slowness while downloading, and see what happens.

3. I don't know the answer to your question regarding bug 645471.
Flags: needinfo?(t8av)
Hi T8av,

I have tested the mentioned issue on latest Firefox release (43.0.4) and latest Nightly (46.0a1) and could not reproduce it. I followed your provided steps and after clearing the cache, the files in progress were not stopped and were successfully downloaded, and no hang occurred.

Firefox: 43.0.4, Build ID: 20160105164030, User Agent: Mozilla/5.0 (Windows NT 6.0; rv:43.0) Gecko/20100101 Firefox/43.0
Firefox: 46.0a1, Build ID: 20160112030227,  User Agent: Mozilla/5.0 (Windows NT 6.0; rv:46.0) Gecko/20100101 Firefox/46.0

Can you please test this on the latest Firefox release (43.0.4) or latest Nightly (46.0a1, https://nightly.mozilla.org/) and tell me if this still reproduces for you ? When doing this please use a new fresh Firefox profile, maybe also in safe mode (https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems). 

Thanks,
Cosmin.
Flags: needinfo?(t8av)
(Reporter)

Comment 7

3 years ago
sorry, i didn't use firefox for long.

if you tested it in the new firefox version and the bug did not occur anymore, maybe you can close this bug.
Flags: needinfo?(t8av)
Considering comment #2 and the fact I can not reproduce this issue on latest Firefox release, I will mark this as RESOLVED - WFM.

Reporter, please feel free to reopen it if you are still having this issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.