Status

()

Core
ImageLib
--
critical
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: tracy, Assigned: Stuart Parmenter)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
seen on widows 2001-05-04-06-trunk

-open a composer new composer window
-select insert image
-select a .jpg image
-enter alternative text

the image isn't added to the page...instead the alternative text is diplayed

Comment 1

17 years ago
I see the problem in composer,

however, images are not loading in browser as well...

http://www.yahoo.com as an example.

this looks like an imagelib issue.

cc: pavlov and tpreston.
(Reporter)

Comment 2

17 years ago
sujay, yes, bug 78860 was filed for browser jpeg issue

Comment 3

17 years ago
assigning to Pav and cc'ing sfraser -- Pav? any ideas why this stopped working?
Assignee: beppe → pavlov

Comment 4

17 years ago
Resolving this bug as "Worksforme"

When I insert a jpg image into Composer, I don't see it (bug #78860) but it *is* 
inserted into Composer.  You can see this by saving the file and looking at it in 
another application or you can view the html source mode and see the <img> tag 
there.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Target Milestone: --- → mozilla0.9.1

Comment 5

17 years ago
Caused by an incorrect fix for bug 77328 (that I sr'd, to my shame).
Try this:

Index: nsJPEGDecoder.cpp
===================================================================
RCS file: /cvsroot/mozilla/modules/libpr0n/decoders/jpeg/nsJPEGDecoder.cpp,v
retrieving revision 1.27
diff -u -r1.27 nsJPEGDecoder.cpp
--- nsJPEGDecoder.cpp   2001/05/04 07:22:38     1.27
+++ nsJPEGDecoder.cpp   2001/05/04 16:45:58
@@ -258,7 +258,7 @@
     mObserver->OnStartDecode(nsnull, nsnull);
 
     /* we only support jpegs with 1 or 3 components currently. */
-    if (mInfo.output_components != 1 ||
+    if (mInfo.output_components != 1 &&
         mInfo.output_components != 3) {
       mState = JPEG_ERROR;
       return NS_ERROR_UNEXPECTED;
Target Milestone: mozilla0.9.1 → ---

Comment 6

17 years ago
yup....
Status: RESOLVED → VERIFIED

Comment 7

17 years ago
Generalize bug, reopen.
Status: VERIFIED → REOPENED
OS: Windows 98 → All
Hardware: PC → All
Resolution: WORKSFORME → ---
Summary: can not insert a jpg image into composer → jpeg images won't load

Comment 8

17 years ago
this is not an editor bug-->ImageLib
Status: REOPENED → NEW
Component: Editor → ImageLib
QA Contact: sujay → tpreston
(Assignee)

Comment 9

17 years ago
r=pavlov.

Comment 10

17 years ago
*** Bug 78917 has been marked as a duplicate of this bug. ***
sr=blizzard

go get 'em tiger.

Comment 12

17 years ago
Checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 13

17 years ago
This is happening on the latest-0.9 build Win32 2001050409
About to check latest-0.9 win32-installer Build 2001050418 ish...

Comment 14

17 years ago
Yippee!!

It works for me!!! latest-0.9 win32-installer Build 2001050417

Comment 15

17 years ago
*** Bug 79001 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
*** Bug 78885 has been marked as a duplicate of this bug. ***

Comment 17

17 years ago
verifying on build 2001-06-11-0.9.1 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.