Massive resource leak when loading large pages

RESOLVED DUPLICATE of bug 75641

Status

()

--
critical
RESOLVED DUPLICATE of bug 75641
18 years ago
18 years ago

People

(Reporter: jimz, Assigned: trudelle)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.8.1+) Gecko/20010430
BuildID:    20010430

When opening a story with a large number of comments in slashdot my Windows
resources go from 70% free to 20% free.  This is the resources reported by
System properties in Win98 under performance tab.  Wintop does not report a
noticeable increase in memory usage, about 2-3 MB, so it does not look like a
general memory leak.  

IE 5.5 does not have a noticeable impact on free resources when loading this page.

Reproducible: Always
Steps to Reproduce:
1. Open System from Control Panel or right click My Computer and select properties.
2. Click Performance tab.  Not Free Resources, close window.
3.  Enter URL into browser:
http://slashdot.org/comments.pl?sid=01%2F05%2F04%2F120243&cid=&pid=0&startat=&threshold=0&mode=thread&commentsort=0&op=Change
4.  Open System from Control Panel or right click My Computer and select properties.
5.  Click Performance tab. Not decrease in free Resources.

Actual Results:  Free resources decreased from 70% free to 20% free.

Expected Results:  Free resource should not decrease at all or by a small amount.

Comment 1

18 years ago
Doesn't happen on my system.  I started with 86%, and after loading the URL, I
still have 86%.  Perhaps display driver related?  Or maybe a problem that's been
fixed since the build you're using?  I'm using build 2001050304, Win98.

Comment 2

18 years ago
wonderful. Is this System, GDI or the other one? [RSRCMTR.EXE will tell you]
Assignee: asa → trudelle
Component: Browser-General → XP Toolkit/Widgets
QA Contact: doronr → jrgm

Comment 3

18 years ago
Timeless, the system resources shown in System Properties is (I believe) the
lower of the two resources, User or GDI.  I think it's the same as the system
resources shown by Resource Meter (the first item in rsc mtr).
(Reporter)

Comment 4

18 years ago
System and User drop equally (about 50%).  GDI drops only 2 percent.

Comment 5

18 years ago
Well, system is simply the lower of the User or GDI numbers, so the real problem 
is User resources dropping.  I can't think what would be using up so much User 
resource, though.

Comment 6

18 years ago
This is a dupe.

*** This bug has been marked as a duplicate of 75641 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
What says this is a dupe?  That bug is about a general memory leak, this bug is
about one of the resource heaps.
You need to log in before you can comment on or make changes to this bug.