[traceback] TypeError: string indices must be integers, not str

RESOLVED WORKSFORME

Status

Marketplace
Consumer Pages
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: krupa, Assigned: ashort)

Tracking

({regression})

2012-09-13
regression
Points:
---

Details

(URL)

(Reporter)

Description

6 years ago
steps to reproduce:
1. Load https://marketplace-dev.allizom.org/

traceback details:
Stacktrace (most recent call last):

  File "django/core/handlers/base.py", line 89, in get_response
    response = middleware_method(request)

  File "commonware/log/middleware.py", line 26, in process_request
    if hasattr(request, 'user') and request.user.is_authenticated():

  File "django/utils/functional.py", line 184, in inner
    self._setup()

  File "django/utils/functional.py", line 248, in _setup
    self._wrapped = self._setupfunc()

  File "django/contrib/auth/middleware.py", line 16, in <lambda>
    request.user = SimpleLazyObject(lambda: get_user(request))

  File "django/contrib/auth/middleware.py", line 8, in get_user
    request._cached_user = auth.get_user(request)

  File "django/contrib/auth/__init__.py", line 98, in get_user
    user_id = request.session[SESSION_KEY]

  File "django/contrib/sessions/backends/base.py", line 39, in __getitem__
    return self._session[key]
TypeError: string indices must be integers, not str
-> ashort to investigate.  I'm not sure if JR's code affected this CCing him too.
Assignee: nobody → ashort
Target Milestone: 2012-09-06 → 2012-09-13
(Assignee)

Comment 2

6 years ago
This appears to have been a transient failure due to changes on the caching backend.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.