Buggy Android Hardware-Keyboard support

RESOLVED WORKSFORME

Status

()

Firefox
Keyboard Navigation
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: Hannes, Unassigned)

Tracking

19 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120824154833

Steps to reproduce:

I am trying to use Firefox v15 on an Android Phone with Hardware-Keyboard (Sony Ericsson Xperia Pro, Android 4.0.4, Build# 4.1.B.0.587). Yet the Hardware-Keyboard does not work properly. It is impossible to enter numbers in forms, as the blue meta-key is ignored.

Strangely, entering the URL www.1.com works as expected.

The shift key works. The Software-Keyboard works (and can be used to enter numbers). The Hardware-Keyboard works with all other apps.

To reproduce go to google.com, try to search for "1". Press the blue-meta-key, then the key label with a white "Q" and a blue "1".


Actual results:

a "q" is displayed in the search form




Expected results:

a "1" should be displayed in the search form
(Reporter)

Updated

6 years ago
OS: Linux → Android
Hardware: x86 → ARM
(Reporter)

Comment 1

6 years ago
Phone User Agent: Mozilla/5.0 (Android; Mobile; rv:15.0) Gecko/15.0 Firefox/15.0
Component: Untriaged → Keyboard Navigation
(Reporter)

Comment 2

6 years ago
The situation has changed with 16.0.1. Entering numbers in Forms using the hardware keyboard is now possible, but the keyboard status indicator is stuck.

Phone User Agent: Mozilla/5.0 (Android; Mobile; rv:16.0) Gecko/16.0 Firefox/16.0

On the top of the Android screen is a status bar. It includes a item that indicates the Keyboard status. Normally it works like this: It displays a little "a" by default, a  "Aa" after pressing the shift key once, and a capital "A" after pressing the shift key twice. It displays a some rectangular icon after pressing the blue key once, and a rectangular icon with a green dot after pressing the blue key twice.

This has the following meanings:
"a" means: small letters
"Aa" means: one capital letter, then small letters again afterwards
"A" means: capital letters
rectangular icon means: one alternate key (blue labels on keyboard), then normal letters again
rectangular icon with green dot means: alternate keys

Expected result:
The keyboard status indicator should work as described above (as it does in the url bar)

Actual result:
The keyboard status indicator just shows "a". Yet the keyboard behaves normally, as if the keyboard status indicator had changed as expected.

This is a usability issue, as the wrong keyboard status indicator is misleading and confusing and it is necessary to type to determine the keyboard status.
(Reporter)

Comment 3

6 years ago
V17.0 behaves just as 16.0.1.
(Reporter)

Comment 4

6 years ago
V18.0 behaves just as 16.0.1.

Please tell me (post here) if you need further information or tests.
Version: 15 Branch → 18 Branch
(Reporter)

Comment 5

5 years ago
The issue is solved in V19.0.
The keyboard status indicator works as expected, both in url bar and html forms.
Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

5 years ago
Version: 18 Branch → 19 Branch
You need to log in before you can comment on or make changes to this bug.