Textarea with placeholder has an invisible caret

RESOLVED DUPLICATE of bug 769405

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 769405
5 years ago
5 years ago

People

(Reporter: Yves ASTIER, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120824154833

Steps to reproduce:

For exemple :
<textarea id="test" placeholder="test text" style="color:#fff;background:#000;"></textarea>


Actual results:

When I come inside the textarea (focus action), the color of the cursor blink (not the cursor mouse) stay black and when I begin to write a text, the cursor blink change in the good color.


Expected results:

I this case, it should be of the color text (like in other brownser) and in this case it must be white.
I can confirm this on Nightly too and on OS X. I'll rephrase the bug.

Steps to Reproduce:
1) Open the data URI
2) Focus the textarea

Expected result:
The caret blinks with a white color.

Actual result:
The caret is invisible (probably blinking with a black color)

Once you actually type one character in the textarea, the caret turns white.
Status: UNCONFIRMED → NEW
Component: Graphics: Text → Layout: Form Controls
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86_64 → All
Version: 15 Branch → Trunk

Updated

5 years ago
Summary: placeholder → Textarea with placeholder has an invisible caret
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 769405
You need to log in before you can comment on or make changes to this bug.