Flash crashes continuously since upgrade to Firefox 15.0 then 15.0.1 with an old version of Trusteer Rapport

RESOLVED DUPLICATE of bug 787014

Status

defect
RESOLVED DUPLICATE of bug 787014
7 years ago
4 years ago

People

(Reporter: phil.kirkley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

upgraded to Firefox 15, then 15.0.1 later. Happens on both, on 2 pcs. 


Actual results:

My home page is BBC news website, with lots of video articles. I keep getting popups when clicking on a story or navigating to a page where there is a video, telling me flash has stopped working. It then reloads and we go through the whole lot 2 seconds later, till I disable. I have downgraded one pc to flash v10 and that seems ok. Both pcs are on vista home. Shockwave flash version is 11.4.402.265. I had updated that because plugins check told me it was out of date. Seems to be latest.


Expected results:

Should not stop working.
(Reporter)

Updated

7 years ago
OS: All → Windows Vista
Hardware: All → x86
The fix in 15.0.1 has backed out a patch about the cache in Private Browsing mode introduced in 15.0 and has nothing to do with plugins.
Can you give a specific URL to reproduce?
Are you in Private Browsing mode (temporary or permanent)?
Can you provide the crash IDs (browser and plugin sides) from about:crashes?
Does it happen in Safe Mode (see https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode)?

Comment 2

7 years ago
Are you perhaps using Trusteer Rapport or another Trusteer product? We have reports that Trusteer causes Flash to crash for some users beginning with Firefox 15.
(Reporter)

Comment 3

7 years ago
Thanks both for comments. I am indeed using Trusteer Rapport, Benjamin. To Scoobidiver: Examples of URLs: http://www.bbc.co.uk/news -> http://www.bbc.co.uk/news/uk-19514794 -> http://www.bbc.co.uk/news/uk-19516079 or http://www.guardian.co.uk/crosswords or just about every page I visit. When I disable flash, don't get aborts but don't get flash. When I re-enable, aborts are constant and continuous. I have sent a number of crash reports. Haven't tried in safe mode yet. I have not been in private browsing mode. I get the "has stopped working" msg about every 2 seconds until I disable. or if I click on a video, I get the "the adobe flas plugin has crashed. Send crash report" msg. I also get this from Windows: "What is Data Execution Prevention?      Data Execution Prevention (DEP) is a security feature that can help prevent damage to your computer from viruses and other security threats. Harmful programs can try to attack Windows by attempting to run (also known as execute) code from system memory locations reserved for Windows and other authorized programs. These types of attacks can harm your programs and files. DEP can help protect your computer by monitoring your programs to make sure that they use system memory safely. If DEP notices a program on your computer using memory incorrectly, it closes the program and notifies you."
(Reporter)

Comment 4

7 years ago
Hi again - I tried Trusteer support and found the bug described there - applied latest version of Rapport as suggested and it now seems to work fine. Thanks for your help.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Summary: Flash crashes continuously since upgrade to Firefox 15.0 then 15.0.1 → Flash crashes continuously since upgrade to Firefox 15.0 then 15.0.1 with an old version of Trusteer Rapport

Updated

7 years ago
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 787014
You need to log in before you can comment on or make changes to this bug.