Closed Bug 789572 Opened 8 years ago Closed 8 years ago

Crash on add-on install with abort message: "We need a context on Android: file ../../../gfx/layers/opengl/LayerManagerOGL.cpp, line 411" - Services.prompt broken

Categories

(Firefox for Android :: Toolbar, defect, critical)

18 Branch
ARM
Android
defect
Not set
critical

Tracking

()

VERIFIED FIXED
Tracking Status
firefox17 --- unaffected
firefox18 --- verified

People

(Reporter: aaronmt, Unassigned)

References

Details

(Keywords: crash, regression, reproducible, Whiteboard: [native-crash])

Crash Data

E/GeckoConsole( 7289): [JavaScript Error: "[Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: resource://gre/modules/XPCOMUtils.jsm :: XPCU_serviceLambda :: line 198"  data: no]" {file: "resource://gre/modules/XPCOMUtils.jsm" line: 198}]
E/BufferQueue(  123): [SurfaceView] connect: already connected (cur=1, req=1)
E/libEGL  ( 7289): EGLNativeWindowType 0x5bdfb010 already connected to another API
E/libEGL  ( 7289): eglCreateWindowSurface:245 error 300b (EGL_BAD_NATIVE_WINDOW)
W/System.err( 7289): org.mozilla.gecko.gfx.GLController$GLControllerException: EGL window surface could not be created! Error 12299
W/System.err( 7289): 	at org.mozilla.gecko.gfx.GLController.provideEGLSurface(GLController.java:176)
W/System.err( 7289): 	at dalvik.system.NativeStart.run(Native Method)
W/System.err( 7289): 	at dalvik.system.NativeStart.run(Native Method)
I/Gecko   ( 7289): ###!!! ABORT: We need a context on Android: file ../../../gfx/layers/opengl/LayerManagerOGL.cpp, line 411
D/Zygote  (  124): Process 7289 terminated by signal (11)
I/WindowState(  311): WIN DEATH: Window{41be99f8 SurfaceView paused=false}
I/ActivityManager(  311): Process org.mozilla.fennec (pid 7289) has died.
W/ActivityManager(  311): Force removing ActivityRecord{418f65c0 org.mozilla.fennec/.App}: app died, no saved state
I/WindowState(  311): WIN DEATH: Window{41b9c6b8 org.mozilla.fennec/org.mozilla.fennec.App paused=false}

STR: Attempt to install an add-on from AMO

bp-76cc57b3-5d90-48c4-a22b-7f8df2120907

--
Nightly (09/07)
Samsung Galaxy Nexus (Android 4.1.1)
Whiteboard: [native-crash][startupcrash] → [native-crash]
(Services.prompt bustage also affects apps installs - but no crash)

E/GeckoConsole( 7734): [JavaScript Error: "Services.prompt is undefined" {file: "chrome://browser/content/browser.js" line: 6276}]
Summary: Crash on add-on install → Crash on add-on install - Services.prompt broken
Additions of search engines are also denied here too.
Crash Signature: [@ mozalloc_abort | browser.db (deleted)@0x2af2c] → [@ mozalloc_abort] [@ mozalloc_abort | browser.db (deleted)@0x2af2c] [@ mozalloc_abort | core.jar@0x1ffe]
Component: General → Graphics, Panning and Zooming
Summary: Crash on add-on install - Services.prompt broken → Crash on add-on install with abort message: "We need a context on Android: file ../../../gfx/layers/opengl/LayerManagerOGL.cpp, line 411" - Services.prompt broken
Blocks: 769894
I suspected this might be fallout from my PromptService.java fix for bug 769894, but I can repro this addon crash with and without my changes.
Matt tried to install an add-on (and seemingly didn't crash) on a build from Sep 5, but we both crash on a build from Sep 7.
mfinkle bisected the Tinderbox builds from m-i and pinpointed the offending changeset as:
https://hg.mozilla.org/integration/mozilla-inbound/rev/020e41f3acbe
No longer blocks: 769894
(In reply to Chris Peterson (:cpeterson) from comment #5)
> mfinkle bisected the Tinderbox builds from m-i and pinpointed the offending
> changeset as:
> https://hg.mozilla.org/integration/mozilla-inbound/rev/020e41f3acbe

If you bisected tinderbox builds, you shouldn't have gotten specifically this one changeset -- this was pushed along with two other csets, and who knows what else was coalesced into this build.

What's the actual regression range?
(In reply to Justin Lebar [:jlebar] from comment #6)
> (In reply to Chris Peterson (:cpeterson) from comment #5)
> > mfinkle bisected the Tinderbox builds from m-i and pinpointed the offending
> > changeset as:
> > https://hg.mozilla.org/integration/mozilla-inbound/rev/020e41f3acbe
> 
> If you bisected tinderbox builds, you shouldn't have gotten specifically
> this one changeset -- this was pushed along with two other csets, and who
> knows what else was coalesced into this build.
> 
> What's the actual regression range?

Actually, I found this range:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=62aeb6b5db75&tochange=48ae6c0a626c

Chris then locally backed out each changeset and found this one to be the real culprit:
https://hg.mozilla.org/integration/mozilla-inbound/rev/020e41f3acbe
Version: Trunk → Firefox 18
I still don't understand why specifically that cset, which merely adds a method to an interface, should cause your crash.  Part 2 of that bug, I'd understand...
> Chris then locally backed out each changeset and found this one to be the real culprit:
> https://hg.mozilla.org/integration/mozilla-inbound/rev/020e41f3acbe

Based on the fact that the patch in bug 789721 fixes this problem, I'd guess that this was the last good changeset instead of the first bad changeset.

It sounds like you manually backed out csets instead of using hg bisect; perhaps that's the source of this error.
Fixed via bug 789721.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Duplicate of this bug: 789885
This crash doesn't occur for me when installing an add-on on Firefox 18. The add-on was installed successfully. 

--
Firefox 18.0a2 (2012-11-19)
Device: Galaxy S2
OS: Android 4.0.3
You need to log in before you can comment on or make changes to this bug.