Social menu items/prompts are inconsistent with the new multi-provider UI

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: markh, Assigned: jboriss)

Tracking

20 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

There is currently a UI element that appears in the Tools menu and/or the "AppMenu" to toggle social functionality on or off.

Currently, this is a "checked" menu item with the text "{provider} for {product}" - eg "Motown for Firefox".  This doesn't seem ideal in a multi-provider world as it implies (to me) that only the named provider will be enabled/disabled, whereas in fact it enables or disables social completely (ie, all providers.)

Boriss: hopefully it is appropriate to assign this to you to make a decision on - please unassign/reassign once a decision is made.
This is more urgent now the multi-provider stuff has landed.  Specifically:

* The menu item "Remove from Firefox" now just removes the current provider.  It should probably say "Remove {provider} from Firefox".  Fortunately the confirmation dialog does imply that only the 1 provider is being removed rather than the entire feature.

* The menu item "Turn off {provider}" is actually turning off *every* provider - ie, it disables the entire social feature.  It should say something closer to "Turn off social features"
OS: Windows 7 → All
Hardware: x86_64 → All
Version: unspecified → 20 Branch
(Assignee)

Updated

6 years ago
Target Milestone: --- → Firefox 20
Target Milestone is used to track when the patch for the bug lands. Clearing the field until a patch lands.
Target Milestone: Firefox 20 → ---
Summary: New text for UI element to toggle social features needed in multi-provider world → Social menu items/prompts are inconsistent with the new multi-provider UI
FWIW, bug 821262 has a patch that makes the UI consistent - just possibly not ideal.
(Assignee)

Comment 4

6 years ago
I'm not able to reproduce the current UI element, but Gavin has kindly provided the screenshots below:

http://cl.ly/image/1b0J0R3w2q3f/Screen%20Shot%202012-12-20%20at%201.51.00%20PM.png
http://cl.ly/image/3J240u1K163D

As Mark notes in Comment 1, let's change the string to "Remove {provider} from Firefox" rather than just have "Remove from Firefox," as the removal is of the current social network rather than SocialAPI as a whole.

On Mark's second point: it's true that turning off {provider} actually turns off the entire SocialAPI integration, rather than just the single provider.  But users are unlikely to associate what they experience as {provider} integration with whatever we name the feature.  However, they don't need to, because turning off a social network does in fact turn off the entire feature from their perspective.  After all, the alternative would be automatically switching to another provider if the user has disabled one, which would be very annoying.  So, I think that keeping "Turn off {provider}" as the string will be sufficient for this release.
(In reply to Jennifer Morrow [:Boriss] (Firefox UX) from comment #4)
> On Mark's second point: it's true that turning off {provider} actually turns
> off the entire SocialAPI integration, rather than just the single provider. 
> But users are unlikely to associate what they experience as {provider}
> integration with whatever we name the feature.  However, they don't need to,
> because turning off a social network does in fact turn off the entire
> feature from their perspective.  After all, the alternative would be
> automatically switching to another provider if the user has disabled one,
> which would be very annoying.  So, I think that keeping "Turn off
> {provider}" as the string will be sufficient for this release.

I'm not so sure about this one.  Let's say the user has installed multiple providers and switch between them regularly using our UI.  I doubt that when they use a menu item which says "Turn off Facebook" they also would expect their other providers to also be turned off?  And once they did this and decided they now wanted to turn "Twitter" (or yammer or whatever) back on, they would find no such UI element for doing this - all they would see is "Turn on Facebook" but that isn't what they want - they want to turn on Twitter.
Bug 837027 landed changes we all agreed on, so this is no longer relevant.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.