Find and Replace: can no longer replace with empty string (replace with nothing to delete matching strings)

RESOLVED DUPLICATE of bug 787673

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 787673
5 years ago
2 years ago

People

(Reporter: Thomas D., Unassigned)

Tracking

({regression})

15 Branch
x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
STR

with TB default settings
1 Write new composition
2 type "foo bar foo bar"
3 Ctrl+F
4 Type into Find Text: "foo" (without quotes); leave Replace With field blank
5 Check Wrap around (optional; to be on the safe side)
6 Try Replace, Replace and Find, or Replace All

Actual result
- first instance of foo is selected
- replacing of foo with empty string does not occur at all

Expected result
- replacing with empty string (remove instances of search string) is an everyday scenario that should work
- Replace-all result should be " bar  bar"

This is a regression.
Works in TB2, still works in TB12Daily_2012-12-31, doesn't work in TB15 release.

Can somebody narrow down the regression range for this bug, between tb12 and tb15?
(Reporter)

Updated

5 years ago
Keywords: regression, regressionwindow-wanted

Comment 1

5 years ago
Dupe of 787673 ?
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 787673
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.