Closed Bug 789696 Opened 11 years ago Closed 11 years ago

Multiple instances of Adobe Flash opening in Firefox v15.0.1 / plug-in crashing with an old version of Trusteer Rapport

Categories

(External Software Affecting Firefox Graveyard :: Flash (Adobe), defect)

x86
Windows Vista
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 787014

People

(Reporter: pat.moody, Unassigned)

Details

(Keywords: crash)

Attachments

(3 files, 1 obsolete file)

285.61 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document
Details
194.39 KB, image/png
Details
99.40 KB, image/png
Details
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

Accessing any web page that includes a video, from Friday September 8 onwards.


Actual results:

Multiple instances of Adobe Flash Player are opened, causing Windows Data Execution Prevention (DEP) to stop Adobe Flash from working and generating lots of error messages, making it impossible to use the web pages in question. 
I closed the Adobe Flash instances in Task Manager to get rid of them.
I have upgraded Adobe Flash Player to version 11.4.r402, but the same problem is still occurring.


Expected results:

A single instance of Adobe Flash should have opened, with no error message generated.
By multiple instances are opening, do you mean that the video is showing up twice?
No, I mean that the video is not opening at all; instead I am getting lots of error messages saying the same thing - that Adobe Flash Player has stopped working. I have included a screenshot with this message in the file attached to the bug report. If you look in the system tray on the screen shot, you can see 5 instances of the error message. It seems that, depending on the page accessed, fewer or more error messages are generated. When I tried to view the YouTube home page, LOTS of duplicate messages were generated.
Another thing I have noticed is that the DEP page you have open is a help page about DEP. Can you give a screenshot of the DEP error showing up, before you click the help button?

The multiple errors are probably because the website uses more than one <embed> (which lets you put flash into a page), which means that it asks for flash multiple times, causing multiple "Adobe Flash is not responding"  errors. Can you try disabling flash in the addons manager (Firefox Menu > Addons > Plugins)

Also, can you try this in Thunderbird seeing as you have it installed? There is an addon called thunderbrowse(https://addons.mozilla.org/thunderbird/addon/thunderbrowse/) which lets you got to websites using thunderbird. Open a new ThunderBrowse tab and try there. Does the same happen?

N.B. to devs - I am asking this question to see if it is a problem with the plugin, but cannot use IE as that uses a separate plugin to FF / Safari / Opera / Chromium Builds
Interesting...
1. I think that the first page of the attached file shows the DEP error before clicking on the help button.
2. Yes, the multiple instances do occur because of more than one embed in the page.
3. Disabling Adobe Flash in the add-ons manager fixed the problem on the page I've been testing on - http://www.britishorienteering.org.uk/.
4. When I then opened a tab using ThunderBrowse (with flash still disabled), there was still no problem on this page.
5. When I re-enabled Flash, there was no problem on the ThunderBrowse tab or my original Firefox tab; in other words the problem seemed to have gone away simply by disabling and re-enabling Adobe Flash.
6. When I exited from Firefox completely and re-entered it, everything was still OK.
7. But then just to be sure, I tried to access the YouTube home page with Flash enabled, and the problem came back, both on a normal Firefox tab and on a ThunderBrowse tab.
Can you please try with Firefox in safe mode and with a new profile (http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles, http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode) and report back if you still see the problem?
Thank you!
I created a new profile and tried it in Firefox safe mode as you requested, but I'm still getting the same problem. I have attached a Word file containing a screenshot of the error message.
(In reply to pat.moody from comment #6)
> I have attached a Word file
> containing a screenshot of the error message.

Please use the format PNG for screenshots.
Sorry, I don't know how to save the screenshot as a png file. Can you please tell me how to do this?
Attachment #660098 - Attachment mime type: application/octet-stream → application/vnd.openxmlformats-officedocument.wordprocessingml.document
Attachment #659488 - Attachment mime type: application/octet-stream → application/vnd.openxmlformats-officedocument.wordprocessingml.document
Thanks. png file now attached for you.
Attachment #660098 - Attachment is obsolete: true
Thanks.
Summary: Multiple instances of Adobe Flash opening in Firefox v15.0.1 → Multiple instances of Adobe Flash opening in Firefox v15.0.1 / plug-in crashing
Can you please paste here the links you get for the crash reports (from about:crashes)?
Thank you!
Sorry but I don't understand your request. I have looked for about:crashes in the Firefox menu structure but can't find it. Please could you explain in a bit more detail what you need.
Please ignore my last comment. I worked out how to get what you need, and have attached a screenshot showing a list of my crash reports. I hope this helps you.
(In reply to pat.moody from comment #14)
> Created attachment 660349 [details]
> Screenshot showing list of crash reports
> 
> Please ignore my last comment. I worked out how to get what you need, and
> have attached a screenshot showing a list of my crash reports. I hope this
> helps you.

We would need the some actual links, not screenshot (click on link from the list and provide the URL where you are redirected).
Also, does disabling Flash Protected Mode help in any way (http://forums.adobe.com/message/4468493)? 
Thanks again!
(In reply to Mihaela Velimiroviciu [QA] from comment #12)
> about:crashes)?

I thought it was about the plug-in crashing, not Firefox.
(In reply to Aleksej [:Aleksej] from comment #16)
> (In reply to Mihaela Velimiroviciu [QA] from comment #12)
> > about:crashes)?
> 
> I thought it was about the plug-in crashing, not Firefox.

Flash crashes (should) appear in about:crashes
URL of most recent crash report is:

https://crash-stats.mozilla.com/report/index/d2172254-7ae7-437e-bacd-768a62120912

and... disabling Flash Protected Mode removes the problem completely.
Component: Untriaged → Flash (Adobe)
Product: Firefox → Plugins
Version: 15 Branch → unspecified
Status: UNCONFIRMED → NEW
Ever confirmed: true
You use an old version of Trusteer Rapport. Please update.
Severity: normal → critical
Status: NEW → RESOLVED
Crash Signature: [@ F1398665248_____________________________ ]
Closed: 11 years ago
Keywords: crash
Resolution: --- → DUPLICATE
Summary: Multiple instances of Adobe Flash opening in Firefox v15.0.1 / plug-in crashing → Multiple instances of Adobe Flash opening in Firefox v15.0.1 / plug-in crashing with an old version of Trusteer Rapport
Thank you very much everyone. I have updated my version of Trusteer Rapport and the problem has gone away.
No longer blocks: F1398665248
Crash Signature: [@ F1398665248_____________________________ ]
Product: External Software Affecting Firefox → External Software Affecting Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.