canvas.drawImage using the output of getUserMedia sometimes fails with "Component not available"

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: derf, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [getUserMedia], [blocking-gum+], URL)

(Reporter)

Description

7 years ago
canvas.drawImage using the output of getUserMedia run through a video tag sometimes fails with "Component not available". This happens very often on anant's Mac, and rarely on my Linux machine, so I suspect some kind of race condition. According to Bas, this can only happen if nsLayoutUtils::SurfaceFromElement() fails with some reason _other_ than mIsStillLoading==true. Possibly this is related to bug 771833?

Reproducible test case:
Related to bug 778682?
Whiteboard: [getUserMedia] → [getUserMedia], [blocking-gum+]
This demo doesn't have any code ensuring that video frames have actually arrived at the <video> element after setting video.src = stream.

The demo could wait for a "canplaythrough" event before it starts doing its drawImage(). Or, once I've fixed bug 778682, the demo could wait for a "loadeddata" event.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Why was this closed as invalid?
(Reporter)

Comment 4

7 years ago
(In reply to Jason Smith [:jsmith] from comment #3)
> Why was this closed as invalid?

I presume because the bug was in the demo (see comment 2). It could also conceivably have been duped to bug 778682.
yes
You need to log in before you can comment on or make changes to this bug.