Can't build using MSVC 9 because it does not provide stdint.h

RESOLVED FIXED in mozilla18

Status

()

--
blocker
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: wgianopoulos, Assigned: Ehsan)

Tracking

({regression})

Trunk
mozilla18
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Using MSVC version 9, the build fails compiling xpcom/glue/nsVersionCompare.cpp because of the lack of stdint.h.  Including mozilla/StandardInteger.h instead of stdint.h as suggested in bug 788014 comment 13 corrects the issue.
(Assignee)

Comment 1

6 years ago
Oops, my bad.  Fixed in https://hg.mozilla.org/integration/mozilla-inbound/rev/1cf703aaa781.
Assignee: nobody → ehsan
Target Milestone: --- → mozilla18
https://hg.mozilla.org/mozilla-central/rev/1cf703aaa781
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.