If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"activate.bat" can not find python when installed in path with spaces on XP

RESOLVED WONTFIX

Status

Add-on SDK
General
P3
normal
RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: andershol, Assigned: aryx)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
I downloaded the SDK version 1.9, unzip'ed it and tried running activate.bat from a command prompt, and go the message "Warning: Failed to find Python installation directory", which is odd since I have both 2.6 and 2.7 installed.

The problem seems to be that python is installed in a path with spaces (i.e. "C:\Program Files\Python27") and the activate script removes spaces from the "PYTHONINSTALL" variable before testing it.

The script seems to work if the script is changed not to remove the spaces, but instead just quote the path, but I guess the space removal must be in there for a reason:

 rem Remove spaces.
-set PYTHONINSTALL=%PYTHONINSTALL: =%
-if exist %PYTHONINSTALL%\python.exe goto :EOF
+if exist "%PYTHONINSTALL%\python.exe" goto :EOF
 rem It may be a 32bit Python directory built from source, in which case the

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

5 years ago
Priority: -- → P3

Updated

5 years ago
Duplicate of this bug: 770467
Blocks: 840023

Comment 2

4 years ago
Also on Windows 7.
Created attachment 8530277 [details] [review]
pull request, v1
Assignee: nobody → archaeopteryx
Status: NEW → ASSIGNED
Attachment #8530277 - Flags: review?(evold)
can we wontfix this?  I'm voting +1 since we are not going to release a new cfx.
Flags: needinfo?(rFobic)
Comment on attachment 8530277 [details] [review]
pull request, v1

I'm going to r- since we aren't going to release a new version of cfx, Irakli can review if he wants to.
Attachment #8530277 - Flags: review?(evold) → review?(rFobic)

Comment 6

3 years ago
"we are not going to release a new cfx" Why not? Is it deprecated and replaced by something else?
Comment on attachment 8530277 [details] [review]
pull request, v1

As Erik has pointed out in previous comment, we are not going to release any new versions of cfx as our future plan is to uplift most functionality to firefox itself & expose cli interface via nodejs (this project lives under https://github.com/mozilla/jpm)

Given that no official release will be made for CFX any more I do not think there is much point in me reviewing this patch.

I'm Cc-ing Jeff who should be able to give a better idea how does the roadmap of tool switch looks like.
Flags: needinfo?(rFobic) → needinfo?(jgriffiths)
Attachment #8530277 - Flags: review?(rFobic)
(In reply to bulwersator from comment #6)
> "we are not going to release a new cfx" Why not? Is it deprecated and
> replaced by something else?

Yes, well, very nearly; the replacement is jpm:

https://github.com/mozilla/jpm

For tips on transitioning, see Erik's excellent blog post:

http://work.erikvold.com/jetpack/2014/08/07/cfx-to-jpm.html

I apologize if this comes as a surprise.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jgriffiths)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.