[dev]Clicking "Add-on home page" returns 403

VERIFIED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
6 years ago
3 years ago

People

(Reporter: AlinT, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 659640 [details]
Page with error message.

1.Got to https://addons-dev.allizom.org/en-US/firefox/addon/memchaser/ (or any addon details page)
2.Click "Add-on home page" link

Expected results:
Add-on home page should be displayed.

Actual results:
Forbidden 403 is returned.
(Reporter)

Updated

6 years ago
Summary: Clicking "Add-on home page" returns 403 → [dev]Clicking "Add-on home page" returns 403
Did outgoing.allizom.org change for bug 786718?
(In reply to Chris Van Wiemeersch [:cvan] from comment #1)
> Did outgoing.allizom.org change for bug 786718?

That's a question for clouserw!

Comment 3

6 years ago
I cannot reproduce this anymore. Was this fixed?
(In reply to krupa raj 82[:krupa] from comment #3)
> I cannot reproduce this anymore. Was this fixed?

http://f.cl.ly/items/3Y0L0C3z3l2q2D2Z113g/Screen%20shot%202012-09-10%20at%2010.34.41%20AM.png

Click on "Add-on home page" (or an external link in summary/description) and it'll take you to https://outgoing.allizom.org/v1/2937cfb1cb844b8d107f44498934f5a2b30ad2a1/https%3A//wiki.mozilla.org/QA/Automation_Services/Projects/Addons/MemChaser

Comment 5

6 years ago
ah, we fixed this in prod but not in dev?
Allen had to roll back his patch.  How things should be right now:

- dev/stage should both be using outgoing.allizom.org now
- outgoing.allizom.org should be updated to accept either the old hashes or hmac

Next steps:

- Allen lands his zamboni patch to use hmac
- QA makes sure URLs using hmac hashes work on -dev
- Next time we push to production outgoing.mozilla.org needs to be svn up'd (this is important or all new links will be broken)
- We file a bug to revisit this at some point in the future to verify: 1) There aren't any *stored* links to outgoing on AMO (using old hashes)  2) No other sites are using outgoing.m.o that haven't converted to hmac    3) Remove the old hash support and only use hmac

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

6 years ago
QA Verified!
Status: RESOLVED → VERIFIED
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.