Closed Bug 789885 Opened 8 years ago Closed 8 years ago

Crash with abort message: "We need a context on Android: file /builds/slave/rel-m-rel-andrd-bld/build/gfx/layers/opengl/LayerManagerOGL.cpp, line 175" while installing extension on ICS

Categories

(Firefox for Android :: Toolbar, defect, critical)

15 Branch
ARM
Android
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 763813
Tracking Status
firefox15 --- affected
firefox16 --- affected
firefox17 --- affected
firefox18 --- affected

People

(Reporter: AdrianT, Unassigned)

Details

(Keywords: crash, Whiteboard: [native-crash])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-bc85a3e7-904d-4cd4-b003-03a5e2120910 .
============================================================= 

Firefox Mobile 15.0/ Nightly 18.0a1 2012-09-09
Samsung Galaxy Tab 2 7.0 (Android 4.0.4) / Sam,sung Galaxy Note (Android 4.0.4)

Steps to reproduce:
1. Open the Add-on Manager
2. Open the AMO page from the Add-on Manager and choose an Add-on -try URL fixer
3. Tap the Add to Firefox button and when the "Installing Add-on" toaster notification is displayed before the Add-on finishes to download tap the Back button twice to return to the Add-on Manager and wait for the add-on download to complete

0 	libmozalloc.so 	TouchBadMemory 	memory/mozalloc/mozalloc_abort.cpp:68
1 	libmozalloc.so 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:89
2 	dalvik-heap (deleted) 	dalvik-heap @0x64c11f 	
3 	dalvik-mark-stack (deleted) 	dalvik-mark-stack @0x30faf40 	
4 	org.mozilla.firefox-1.apk 	org.mozilla.firefox-1.apk@0x572038 	
5 	org.mozilla.firefox-1.apk 	org.mozilla.firefox-1.apk@0x656e1e 	
6 	dalvik-heap (deleted) 	dalvik-heap @0x650e6d 	
7 	org.mozilla.firefox-1.apk 	org.mozilla.firefox-1.apk@0x6c6964 	
8 	libxul.so 	mozilla::plugins::PluginModuleChild::AnswerPPluginInstanceConstructor 	dom/plugins/ipc/PluginModuleChild.cpp:2015
9 	org.mozilla.firefox-1.apk 	org.mozilla.firefox-1.apk@0x6f8c45 	
10 	org.mozilla.firefox-1.apk 	org.mozilla.firefox-1.apk@0x6e696a 	
11 	libdvm.so 	libdvm.so@0x50859 	
12 	libc.so 	libc.so@0x15ae7 	
13 	dalvik-heap (deleted) 	dalvik-heap @0x202e 	
14 	libdvm.so 	libdvm.so@0x1eebe 	
15 	libc.so 	libc.so@0x16149 	
16 	libdvm.so 	libdvm.so@0x73341 	
17 	core.odex 	core.odex@0x7a0f4 	
18 	dalvik-heap (deleted) 	dalvik-heap @0x16ebe 	
19 	libdvm.so 	libdvm.so@0x1eebe 	
20 	libdvm.so 	libdvm.so@0x30b8e 	
21 	libdvm.so 	libdvm.so@0xb3f9a 	
22 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x347e 	
23 	libdvm.so 	libdvm.so@0x34372 	
24 	dalvik-heap (deleted) 	dalvik-heap @0x8a74c6 	
25 	dalvik-heap (deleted) 	dalvik-heap @0x8a74c6 	
26 	core.odex 	core.odex@0x7a29a 	
27 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x24db66 	
28 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x347e 	
29 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x347e 	
30 	libdvm.so 	libdvm.so@0x6cb59 	
31 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x347e 	
32 	libc.so 	libc.so@0x15ae7 	
33 	dalvik-heap (deleted) 	dalvik-heap @0x202e 	
34 	data@app@org.mozilla.firefox-1.apk@classes.dex 	data@app@org.mozilla.firefox-1.apk@classes.dex@0x10ad2c 	
35 	dalvik-heap (deleted) 	dalvik-heap @0x67ceae 	
36 	dalvik-heap (deleted) 	dalvik-heap @0x78f5ae 	
37 	libc.so 	libc.so@0x16149 	
38 	dalvik-heap (deleted) 	dalvik-heap @0x202e 	
39 	libdvm.so 	libdvm.so@0x76a33 	
40 	dalvik-heap (deleted) 	dalvik-heap @0x78f5ae 	
41 	dalvik-heap (deleted) 	dalvik-heap @0x202e 	
42 	core.odex 	core.odex@0x79af6 	
43 	dalvik-heap (deleted) 	dalvik-heap @0x7c82e6 	
44 	libdvm.so 	libdvm.so@0x59989 	
45 	dalvik-heap (deleted) 	dalvik-heap @0x67ceae 	
46 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x2f970e 	
47 	libc.so 	libc.so@0x3a00f 	
48 	dalvik-heap (deleted) 	dalvik-heap @0x7c82e6 	
49 	libdvm.so 	libdvm.so@0x755d7 	
50 	dalvik-heap (deleted) 	dalvik-heap @0x671016 	
51 	dalvik-heap (deleted) 	dalvik-heap @0x7c82e6 	
52 	libdvm.so 	libdvm.so@0xb3f9a 	
53 	dalvik-heap (deleted) 	dalvik-heap @0x7c82e6 	
54 	dalvik-heap (deleted) 	dalvik-heap @0x7c82e6 	
55 	libdvm.so 	libdvm.so@0x74a7b 	
56 	dalvik-heap (deleted) 	dalvik-heap @0x7c82e6 	
57 	libc.so 	libc.so@0x14c83 	
58 	dalvik-heap (deleted) 	dalvik-heap @0x7c82e6 	
59 	dalvik-heap (deleted) 	dalvik-heap @0x7c82e6 	
60 	libdvm.so 	libdvm.so@0x5b5fb 	
61 	dalvik-heap (deleted) 	dalvik-heap @0x7c82e6 	
62 	libdvm.so 	libdvm.so@0x7687b 	
63 	libnspr4.so 	PR_AtomicDecrement 	nsprpub/pr/src/misc/pratom.c:280
64 	libnspr4.so 	pt_PostNotifies 	nsprpub/pr/src/pthreads/ptsynch.c:125
65 	libnspr4.so 	PR_Unlock 	nsprpub/pr/src/pthreads/ptsynch.c:208
66 	libxul.so 	nsAppShell::NotifyNativeEvent 	Mutex.h:83
67 	libxul.so 	nsAppShell::PostEvent 	widget/android/nsAppShell.cpp:780
Dupe of bug 763813?
Component: General → Graphics, Panning and Zooming
Summary: Crash Report [@ TouchBadMemory | mozalloc_abort | org.mozilla.firefox-1.apk@0x572038 ] on ICS → Crash with abort message: "We need a context on Android: file /builds/slave/rel-m-rel-andrd-bld/build/gfx/layers/opengl/LayerManagerOGL.cpp, line 175" while installing extension
Whiteboard: [native-crash]
Performing the steps on Android pre-ICS (2.3.4 and 3.1) results in the bug 789888
Summary: Crash with abort message: "We need a context on Android: file /builds/slave/rel-m-rel-andrd-bld/build/gfx/layers/opengl/LayerManagerOGL.cpp, line 175" while installing extension → Crash with abort message: "We need a context on Android: file /builds/slave/rel-m-rel-andrd-bld/build/gfx/layers/opengl/LayerManagerOGL.cpp, line 175" while installing extension on ICS
(In reply to Scoobidiver from comment #1)
> Dupe of bug 763813?

Yeah, pretty much. It's different STR but the same underlying bug.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 763813
Status: RESOLVED → VERIFIED
Bug 789572 is the true dupe.
Duplicate of bug: 789572
(In reply to Mark Finkle (:mfinkle) from comment #4)
> Bug 789572 is the true dupe.
Reduping because bug 789572 is a regression in 18.0 and the line number is different.
Duplicate of bug: 763813
You need to log in before you can comment on or make changes to this bug.