Firefox in "use system proxy settings" configuration does not check ProxyEnable from registry

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
3 years ago

People

(Reporter: valeriu, Unassigned)

Tracking

15 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-backlog])

(Reporter)

Description

6 years ago
I have Firefox 15.0.1 and IE 6.0.
Firefox is in "Use system proxy settings" configuration.
Sometimes I use proxy. But when I disable proxy in IE, Firefox still download through proxy.
Seems he does not check parameter ProxyEnable in "HCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings" .
IE does not erase parameters "ProxyServer" in the same branch of registry and Firefox still use it.
Probably already fixed with bug 771115

Reporter: Did this work with Firefox14 ?
Component: General → Networking: HTTP
Product: Firefox → Core
Whiteboard: [necko-backlog]
(Reporter)

Comment 2

3 years ago
I dont know how work Firefox 14.
Now I use latest version - 44.0.2 - an all work perfectly.

If you can send me a link to FF 14 portable version - I can try to check. :)
(Reporter)

Comment 3

3 years ago
Found Firefox 14 and 15.
tested :
1) change proxy in IE. Firefox sees the change and is working correctly.
2) change proxy directly in registry. Same effect - Firefox working correctly.

But - difference between 2012 and 2016 :
2012 - Windows XP SP2 and IE 6
2016 - Windows XP SP3 and IE 8
Maybe these changes affected the result.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.