Closed Bug 78992 Opened 19 years ago Closed 16 years ago

HR with size="1" (height) produces size="2" effect.

Categories

(Core :: Layout, defect, P3, minor)

x86
Windows 98
defect

Tracking

()

RESOLVED FIXED
Future

People

(Reporter: mgalli, Assigned: attinasi)

References

Details

(Keywords: regression, testcase)

Attachments

(6 files, 1 obsolete file)

Whatever value I try with size attribute in HR element, there is no action.

Build Gecko/20010504
win98
will attach simple test.
What are you expecting to happen?
The size attribute specifies the height of the HR element.
If you set the size to be 10, you'll correctly get an HR element with the
correct height.
Summary: HR with size="1" is not working. → HR with size="1" is not working.
In the build I tested the size=1 produced the size=2 effect. Seems like its
working for you. Roger, do you confirm this?
Yeah! Linux nb 2001050121 showing hr element with incorrect size (height).
Marking NEW based on confirmation.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Adding aruner....cc... as an FYI watcher...
This displays properly under mozilla 0.8
so marking.. regression
Keywords: regression
*** Bug 83780 has been marked as a duplicate of this bug. ***
Changing the summary. 
Summary: HR with size="1" is not working. → HR with size="1" (height) produces size="2" effect.
HTML Element component is deprecated, and should be removed from Bugzilla.
Clayton is not the correct owner for these. Reassigning to layout.
Assignee: clayton → karnaze
Component: HTML Element → Layout
QA Contact: bsharma → petersen
*** Bug 102025 has been marked as a duplicate of this bug. ***
prize=pizza (whoever fix this bug marcio will pay a pizza). 
*** Bug 105413 has been marked as a duplicate of this bug. ***
We are making the hr larger than 1 pixel, unlike IE and Nav. -->attinasi.
Assignee: karnaze → attinasi
Severity: normal → minor
Target Milestone: --- → mozilla1.0.1
Attached file Testcase
This is a testcase with 4 <HR>s in the following order:

<hr/>
<hr size="1"/>
<hr size="8"/>
<hr size="8" NOSHADE/>
Attached image IE 5.5 output
IE 5.5 on Windows 98's output for the testcase
Attached image NS 4.x's output
NS 4.x's rendering of the testcase
A Mozilla 2001-11-08 rendering of the testcase.
Attached image Mozilla patched output
The rendering of Mozilla with a patch of mine applied.
As the screenshots reveal NOSHADE is broken in both the current Mozilla and the 
old NS4.x. It does only work in IE5.5 where it renders the HR solid with 
NOSHADE on.

It also looks (according to the screenshot of my patched build) that my patch 
fixes this bug.
Attached patch Patch -u (obsolete) — Splinter Review
Patch for this bug.
That patch is not correct, it has a bad, old regression.

I'll try to come up with a better fix.
I would recommend not fixing this. Instead, let's get my fix for bug 38370
massaged into the post-hyatt-rule-system world and then let's fix the bugs
blocking that. That should make _this_ bug disappear on its own.
Depends on: 38370
Attachment #57822 - Attachment is obsolete: true
*** Bug 127146 has been marked as a duplicate of this bug. ***
bug 58447 and bug 55475 seem related.
Moving Mozilla 1.01 bugs to 'future' milestone with priority P1

I will be pulling bugs from 'future' milestones when scheduling later work.
Priority: -- → P1
Target Milestone: mozilla1.0.1 → Future
*** Bug 144557 has been marked as a duplicate of this bug. ***
*** Bug 150465 has been marked as a duplicate of this bug. ***
Can we move this to next milestone? I advocate mozilla/NN and this was the first
bug.

Tnx.
*** Bug 151392 has been marked as a duplicate of this bug. ***
*** Bug 173814 has been marked as a duplicate of this bug. ***
Priority: P1 → P3
Keywords: testcase
Fixed by bug 38370
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.