Last Comment Bug 790015 - Lightning/Thunderbird build is broken after Bug 789382
: Lightning/Thunderbird build is broken after Bug 789382
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Lightning Only (show other bugs)
: Lightning 2.0
: All All
: -- normal (vote)
: 2.0
Assigned To: Stefan Sitter
:
:
Mentors:
: 790157 (view as bug list)
Depends on: 789382 790157
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-10 11:50 PDT by ojab
Modified: 2012-09-13 10:37 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
possible untested fix (2.16 KB, patch)
2012-09-11 09:54 PDT, Daniel Holbert [:dholbert]
no flags Details | Diff | Splinter Review
bustage fix (3.32 KB, patch)
2012-09-11 10:06 PDT, Stefan Sitter
ssitter: review+
philip.chee: feedback+
Details | Diff | Splinter Review

Description ojab 2012-09-10 11:50:48 PDT
/sources/comm-central/calendar/base/src/calUtils.cpp: In function ‘nsresult cal::logError(const PRUnichar*)’:
/sources/comm-central/calendar/base/src/calUtils.cpp:19:94: error: no matching function for call to ‘nsIScriptError::Init(const PRUnichar*&, NULL, NULL, int, int, nsIScriptError::<anonymous enum>, const char [9])’
/sources/comm-central/calendar/base/src/calUtils.cpp:19:94: note: candidate is:
In file included from /sources/comm-central/calendar/base/src/calUtils.cpp:5:0:
../../../mozilla/dist/include/nsIScriptError.h:72:14: note: virtual nsresult nsIScriptError::Init(const nsAString&, const nsAString&, const nsAString&, uint32_t, uint32_t, uint32_t, const char*)
../../../mozilla/dist/include/nsIScriptError.h:72:14: note:   no known conversion for argument 1 from ‘const PRUnichar* {aka const short unsigned int*}’ to ‘const nsAString&’
/sources/comm-central/calendar/base/src/calUtils.cpp: In function ‘nsresult cal::logWarning(const PRUnichar*)’:
/sources/comm-central/calendar/base/src/calUtils.cpp:27:96: error: no matching function for call to ‘nsIScriptError::Init(const PRUnichar*&, NULL, NULL, int, int, nsIScriptError::<anonymous enum>, const char [9])’
/sources/comm-central/calendar/base/src/calUtils.cpp:27:96: note: candidate is:
In file included from /sources/comm-central/calendar/base/src/calUtils.cpp:5:0:
../../../mozilla/dist/include/nsIScriptError.h:72:14: note: virtual nsresult nsIScriptError::Init(const nsAString&, const nsAString&, const nsAString&, uint32_t, uint32_t, uint32_t, const char*)
../../../mozilla/dist/include/nsIScriptError.h:72:14: note:   no known conversion for argument 1 from ‘const PRUnichar* {aka const short unsigned int*}’ to ‘const nsAString&’
make[8]: *** [calUtils.o] Error 1
Comment 1 Daniel Holbert [:dholbert] 2012-09-11 08:06:41 PDT
Conveniently, the bustage here is limited to the file in comment 0 (calUtils)

That has the only instances of "scripterror" in comm-central's cpp files on MXR:
 https://mxr.mozilla.org/comm-central/search?string=scripterror&find=cpp%24&findi=&filter=^[^\0]*%24&hitlimit=&tree=comm-central
(ignoring /mozilla subdir which appears to be straight m-c)
Comment 2 Daniel Holbert [:dholbert] 2012-09-11 09:54:09 PDT
Created attachment 660134 [details] [diff] [review]
possible untested fix

For reference, here's a fix I'd spun up (hadn't attached it yet because I didn't yet have a comm-central build & couldn't test it).

Stefan: feel free to take this and run with it -- maybe you've already generated something similar yourself. :)
Comment 3 Daniel Holbert [:dholbert] 2012-09-11 09:56:47 PDT
*** Bug 790157 has been marked as a duplicate of this bug. ***
Comment 4 Stefan Sitter 2012-09-11 10:06:53 PDT
Created attachment 660140 [details] [diff] [review]
bustage fix
Comment 5 Daniel Holbert [:dholbert] 2012-09-11 10:33:53 PDT
(bustage fix looks good to me, FWIW! Thanks, and sorry for causing the bustage.)
Comment 6 Philip Chee 2012-09-12 03:56:02 PDT
Comment on attachment 660140 [details] [diff] [review]
bustage fix

This patch allows my build to complete and no obvious errors on startup.
Comment 7 Stefan Sitter 2012-09-13 10:29:53 PDT
Comment on attachment 660140 [details] [diff] [review]
bustage fix

It seem that Philipp is not available at the moment. I therefore set r+ myself based on the positive feedback above to check in the bustage fix.
Comment 8 Stefan Sitter 2012-09-13 10:37:40 PDT
Pushed to https://hg.mozilla.org/comm-central/rev/6d5b06e82381

Note You need to log in before you can comment on or make changes to this bug.