Bug 79008 (ScrollbarCSS)

no support for w3c css2 scrollbar tag

RESOLVED INVALID

Status

()

Core
Layout
--
minor
RESOLVED INVALID
17 years ago
13 years ago

People

(Reporter: crazney, Assigned: clayton)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.4-pre3 i686; en-US; 0.8.1)
BuildID:    2001040608

maybe its just me, but the css tags "scroll-bar-SOMETHING" dont seem to render
in mozilla?
body { background-color: #4D5863; color: #000000; scrollbar-face-color: red; }

Reproducible: Always
Steps to Reproduce:
1.create an html document with this body css class:
body { background-color: #4D5863; color: #000000; crollbar-face-color: red; }
2. run it

Actual Results:  normal scrollbar

Expected Results:  scrollbar should be red.

Comment 1

17 years ago
Those are IE5.5 extensions to css.  Take a look at the spec and tell me where
you find scrollbar-[something]-color anywhere there?

http://www.w3.org/TR/REC-CSS2/propidx.html

Look here to find the properties explained for IE5.5

http://msdn.microsoft.com/workshop/Author/css/reference/attributes.asp

scrollbar colors can be change throught the userChrome.css user style sheet in
your profile directory in the chrome folder

Look here to see how to customize the user interface

http://www.mozilla.org/unix/customizing.html

I didn't see exactly where scrollbar color could be changed, but different skins
have different scrollbar colors and behaviors, so it can be done...and to a much
greater degree than IE5.5 allows.

I don't mean to be rude, but please check your facts before posting a bug
report.   Mozilla not implementing IE's proprietary features are not necessarily
a bug.  If you want to phrase this as more of a feature requrest, then that
could be considered, but this most certainly is *not* at bug.

Therefore, this bug should be marked invalid unless you are specifically asking
for Mozilla to support IE5.5's proprietary feature.  Also, the component should
be style system, not HTML Element.

jake
Confirming, these properties are MS proprietary extensions to CSS.
==> marking INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout

Updated

16 years ago
QA Contact: bsharma → moied

Comment 4

13 years ago
*** Bug 278613 has been marked as a duplicate of this bug. ***
*** Bug 278794 has been marked as a duplicate of this bug. ***
Alias: ScrollbarCSS
*** Bug 282535 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.