Typing 'ç' or 'ß' or does not work in content fields - Samsung keyboard Galaxy SII and Note

RESOLVED WORKSFORME

Status

()

defect
P3
normal
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: reuben, Assigned: jchen)

Tracking

unspecified
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec+)

Details

Reporter

Description

7 years ago
STR:
1) Go to google.com
2) Type 'ç' (long press on C) on the search field

Actual results:
Nothing appears

Expected results:
Character is shown in the text field.
Thanks for the report.  Can you let us know what version of Firefox you're using, what Android device/OS, and what type of keyboard?
Component: General → Keyboards and IME
Product: Fennec → Firefox for Android
Version: Trunk → unspecified
Reporter

Comment 2

7 years ago
(In reply to Matt Brubeck (:mbrubeck) from comment #1)
> Thanks for the report.  Can you let us know what version of Firefox you're
> using, what Android device/OS, and what type of keyboard?

Today's Nightly, Galaxy S2/CyanogenMod 9, built-in Android keyboard.
I can confirm this in Firefox nightly 2012-09-10 v18.0a1 on a stock Galaxy SII Android 4.0.4 and a stock Galaxy Note. This is only a problem in content. Almost all other long press special glyphs print fine. The only other glyph on the keyboard I could find that was broken was the German glyph ß.

SII reports the keyboard as Samsung Keypad version 4.0.4-XWLPT

This works fine on the Galaxy SIII and Nexus S

SIII reports the keyboard as Samsung Keyboard version 1.0
Summary: Typing 'ç' doesn't work in content inputs → Typing 'ç' or 'ß' or does not work in content fields - Samsung keyboard Galaxy SII and Note
tracking-fennec: --- → ?
Forgot to mention this is not a regression. The behavior is reproducible going back to Fx 15.
Reporter

Comment 5

7 years ago
This is not reproducible on Jelly Bean.
Assignee: nobody → cpeterson
tracking-fennec: ? → +
tracking-fennec: + → ---
Priority: -- → P3
tracking-fennec: --- → +
Duplicate of this bug: 806183
I can take this. Should be fixed once Bug 805162 lands.
Assignee: cpeterson → nchen
Status: NEW → ASSIGNED
Depends on: 805162
No longer reproducible after Bug 805162.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 817331
You need to log in before you can comment on or make changes to this bug.