Last Comment Bug 790181 - Permanent orange: test_bug248970_cache.js hangs without private browsing enabled on aurora and beta
: Permanent orange: test_bug248970_cache.js hangs without private browsing enab...
Status: RESOLVED FIXED
: intermittent-failure
Product: Core
Classification: Components
Component: Networking: HTTP (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla17
Assigned To: Mark Banner (:standard8)
:
:
Mentors:
Depends on:
Blocks: pbchannelfail
  Show dependency treegraph
 
Reported: 2012-09-11 02:56 PDT by Mark Banner (:standard8)
Modified: 2012-11-25 19:31 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
The fix (diff -w) (801 bytes, patch)
2012-09-11 02:56 PDT, Mark Banner (:standard8)
ehsan: review+
Details | Diff | Splinter Review
The fix (full patch) (2.57 KB, patch)
2012-09-11 02:57 PDT, Mark Banner (:standard8)
lukasblakk+bugs: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Mark Banner (:standard8) 2012-09-11 02:56:05 PDT
Created attachment 660019 [details] [diff] [review]
The fix (diff -w)

Since bug 787743 landed, we're seeing permanent hangs on aurora and beta channels for Thunderbird:

TEST-INFO | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit/test_bug248970_cache.js | running test ...

command timed out: 1200 seconds without output, attempting to kill

This is due to the private browsing service not being defined. I think this is because the test changed a bit between landing and backout, and the backout didn't fully take account of this.
Comment 1 Mark Banner (:standard8) 2012-09-11 02:57:07 PDT
Created attachment 660021 [details] [diff] [review]
The fix (full patch)
Comment 2 Josh Matthews [:jdm] 2012-09-11 03:07:35 PDT
Thank you and sorry :(
Comment 3 :Ehsan Akhgari 2012-09-11 15:20:31 PDT
Comment on attachment 660019 [details] [diff] [review]
The fix (diff -w)

Who says I can't make embarrassing mistakes?  Just point them to this bug!  :-)

Thanks for fixing this.
Comment 4 Mark Banner (:standard8) 2012-09-11 23:08:07 PDT
Comment on attachment 660021 [details] [diff] [review]
The fix (full patch)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 787743
User impact if declined: None
Testing completed (on m-c, etc.): None, test-only change
Risk to taking this patch (and alternatives if risky): None, test-only
String or UUID changes made by this patch: None

This fixes test-only bustage for gecko apps that don't have private browsing enabled.

Note You need to log in before you can comment on or make changes to this bug.