Address bar: Wrong page loaded after clicking on an entry of the autocomplete (history) if one is too fast




Address Bar
6 years ago
5 years ago


(Reporter: Rainer Rillke, Unassigned)


15 Branch
Windows XP

Firefox Tracking Flags

(Not tracked)




6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

* Starting Firefox
* Entering "sup" into the address bar using the keyboard
* Because is in the history, Firefox suggests me going to that page in an autocomplete / list
* On the list of proposals, immediately click (using the mouse) the first entry after it is shown (if you wait longer, it works as expected)

Actual results:

Firefox started a google search (which it is told to do when entering invalid things into the address bar) for the term "sup"

Expected results:

Firefox should load

Comment 1

6 years ago
I'm having some trouble reproducing this issue on
Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/18.0 Firefox/18.0

I am clicking in the list of proposal but the pages are loading as expected.


6 years ago
Component: Untriaged → Location Bar

Comment 2

6 years ago
I am still experiencing this issue with Firefox/15.0.1 .
It only happens when the browser is busy doing other things like directly after starting or while it loads other heavy pages.

Comment 3

5 years ago
Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20130805 Firefox/24.0
Mozilla/5.0 (Windows NT 5.1; rv:25.0) Gecko/20100101 Firefox/25.0

WFM on latest Nightly (Build ID: 20130805030205) and Aurora (Build ID: 20130805004006) when I enter "mozilla" in the address bar. If I enter "support" in the address bar with a new profile, I get 0 autocomplete results; this is expected since is not in History, but is.

Setting the Status of this bug to Resolved Worksforme; if anyone still encounters this issue please reopen.
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Comment 4

5 years ago
It isn't hard to reproduce (at least another aspect of the presumably same bug), but you have to be fast:

If you have a lot of bugzilla entries in your history, enter


wait until the auto-suggestions open, then type Backspace and then x. There is now


in your address bar. Notice that the auto-suggest entries do not disappear immediately. Click one of the entries that should not be there (and will be removed after a while).

Result: Either you are directed to http://www.bug.cgx/ (server not found) or a Google search is performed (based on your settings).

This is annoying if you accidentally typed the wrong letter.

Expected result: Go to the page I clicked.

Aber wahrscheinlich ist das hier genauso ein Projekt wie Wikimedia, bei dem man besser alles selber macht, weil man dann schneller fährt und die Devs fest davon überzeugt sind, perfekte Software gemacht zu haben.

In reply to comment 3:
> I get 0 autocomplete results; this is expected since 
> is not in History
Never said, that I never visited with that profile before.
Resolution: WORKSFORME → ---
You need to log in before you can comment on or make changes to this bug.