If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Fix build with xcode 4.1's clang

RESOLVED DUPLICATE of bug 784631

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 784631
5 years ago
5 years ago

People

(Reporter: espindola, Assigned: espindola)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 660115 [details] [diff] [review]
patch

While we don't build with the clang in xcode 4.1, supporting it makes it easier for others to build on OS X.

It also looks like not producing an error in here is a regression in newer clangs (they just don't call the DebugOnly destructor), so it is more future proof to avoid it.
Attachment #660115 - Flags: review?(dmandelin)
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 784631
Attachment #660115 - Flags: review?(dmandelin)
You need to log in before you can comment on or make changes to this bug.