Autocomplete for drop-down boxes

RESOLVED DUPLICATE of bug 1309935

Status

()

enhancement
RESOLVED DUPLICATE of bug 1309935
19 years ago
3 years ago

People

(Reporter: matthew, Unassigned)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9+) Gecko/20010504
BuildID:    2001050420

We need to add autocompletion for drop-down list boxes.  Right now, all we have
is the ability to type the first character and cycle through the matching ones.
 What should appear is an autocomplete box like the URL bar that minimizes
choices as one types.

Reproducible: Always
Steps to Reproduce:
Click a drop down box with countries listed, type "C" and try to find Canada.

Actual Results:  Repeatedly hitting "C" goes through all the C countries

Expected Results:  It should pop up a box containing entries like:

Cambodia
Canada
Columbia

etc...

Hitting the next key should narrow the box down again.

This is a feature not available in any browser I've seen so far - it would
definately be a good way to set Mozilla apart.
Setting severity to enhancement...
Severity: normal → enhancement
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: PC → All
Yes, I like this idea, but it requires a timer, more work.....
Status: NEW → ASSIGNED
Target Milestone: --- → Future
See also bug 92491, the same bug for XBL form controls.  Bug 92491 has some 
discussion about how this feature should work.

By the way, this bug will become a dup of 92491 if bug 57209 (use XBL form 
controls for HTML forms) is fixed.  There seems to be a precendent of 
WONTFIXing bugs that will be made moot by that change, but I'm not comfortable 
with that because those wontfixes aren't being tracked in case someone later 
decides not to XBLify form controls.
Please note- this is not the same bug.  This bug involved autocompleting for the
drop down boxes, not just jumping to an item based on the first letter.

You mean something like this?

http://www.visi.com/~hoju/mozilla/selectobjectdemo/selectobjdemo.html

well, maybe not exactly, but it provides some pretty good combo-box like
functionality using the w3c DOM and w3c Event models combined with some oop
javascript.  BTW, this works in both Mozilla and IE5.5+ (haven't tested anything
below that) and it can also fall back to using the standard DOM Level0 non w3c
DOM and w3c Event model browsers like Netscape4 and Opera.

Jake
That's exactly what I was thinking!
This is sort of related to bug 163532 (one might say a dup but I think one would
be wrong).
I think this would be a little more advanced than that bug.  This would actually
filter the displayed list as you type, showing available choices that match what
has been typed.
this is almost a dup of bug 150590
Summary: [RFE] Autocomplete for drop-down boxes → Autocomplete for drop-down boxes
how to sort autocomplete
Ignore that last comment I posted.
Assignee: rods → nobody
Status: ASSIGNED → NEW
QA Contact: vladimire → layout.form-controls
Bug 1309935 implemented this though it doesn't focus the search box by default.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1309935
You need to log in before you can comment on or make changes to this bug.