bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Refactor Marionette testrunner to make Gaia testing easier

RESOLVED FIXED in mozilla18

Status

Testing
Marionette
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: jgriffin, Assigned: jgriffin)

Tracking

unspecified
mozilla18
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

6 years ago
This patch does a couple of things:

 - it adds a console entry point for Marionette ("marionette") that allows you to run Marionette tests from anywhere; you don't need to be in the directory where runtests.py lives
 - it makes it possible to subclass the testrunner to provide a custom test class

I've already tested that these changes are harmless to current automation, and that they work for the target use case; that is, I've created a GaiaTestClass which exposes some unique methods applicable to Gaia testing, and verified I could run tests with them independent of Marionette's pre-existing test classes.  I'll submit the Gaia-related changes in a separate patch.
(Assignee)

Comment 1

6 years ago
Created attachment 660250 [details] [diff] [review]
Refactor Marionette testrunner to make it easier to write Gaia tests,
Attachment #660250 - Flags: review?(mdas)
(Assignee)

Comment 2

6 years ago
Created attachment 660251 [details] [diff] [review]
Refactor Marionette testrunner to make it easier to write Gaia tests,

Realized I should have bumped the version here as well
Attachment #660251 - Flags: review?(mdas)
(Assignee)

Updated

6 years ago
Attachment #660250 - Attachment is obsolete: true
Attachment #660250 - Flags: review?(mdas)
(Assignee)

Updated

6 years ago
Blocks: 790469
(Assignee)

Updated

6 years ago
Assignee: nobody → jgriffin
Comment on attachment 660251 [details] [diff] [review]
Refactor Marionette testrunner to make it easier to write Gaia tests,

Review of attachment 660251 [details] [diff] [review]:
-----------------------------------------------------------------

This looks great, thanks!

::: testing/marionette/client/marionette/marionette_test.py
@@ +52,1 @@
>      def kill_gaia_app(self, url):

We should probably remove this and kill_gaia_apps from the CommonTestCase class
Attachment #660251 - Flags: review?(mdas) → review+
bug 787114 was created to deal with the gaia helper functions, but I think we can change that here and close this bug
(Assignee)

Updated

6 years ago
Duplicate of this bug: 787114
(Assignee)

Comment 6

6 years ago
(In reply to Malini Das [:mdas] from comment #4)
> bug 787114 was created to deal with the gaia helper functions, but I think
> we can change that here and close this bug

I agree, I duped that bug and will remove those functions with this patch.
(Assignee)

Comment 7

6 years ago
Created attachment 661383 [details] [diff] [review]
Refactor Marionette testrunner to make it easier to write Gaia tests,

Updated patch to remove unneeded Gaia methods, pushed to try: https://tbpl.mozilla.org/?tree=Try&rev=dc20b5313b8f
(Assignee)

Updated

6 years ago
Attachment #660251 - Attachment is obsolete: true
(Assignee)

Comment 8

6 years ago
Comment on attachment 661383 [details] [diff] [review]
Refactor Marionette testrunner to make it easier to write Gaia tests,

Carrying r+ forward
Attachment #661383 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/8d96a5392ff4
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.