feed-parser.js raises an error with buggy RSS feeds; Error: linkElements is null

RESOLVED FIXED in Thunderbird 18.0

Status

MailNews Core
Feed Reader
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Yoshihisa Kawamoto, Assigned: alta88)

Tracking

Thunderbird 18.0
Bug Flags:
in-testsuite ?

Thunderbird Tracking Flags

(thunderbird16 fixed, thunderbird17 fixed)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 660355 [details] [diff] [review]
feed-parser.js.patch

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

Following feed URL does not work anymore. There is a RSS feed of the Google Hot Trends in my News Feeds subscription list:
http://www.google.com/trends/hottrends/atom/hourly
This feed URL is not legitimate, invalid, or buggy, but very useful. And this URL worked well up to Thunderbird 14.


Actual results:

When I update the feed (File -> Get New Messages for -> Blogs & News Feeds), a following error is raised in the Error Console:
Timestamp: 9/12/12 5:42:14 PM
Error: linkElements is null
Source File: chrome://messenger-newsblog/content/feed-parser.js
Line: 597

This may be caused by the buggy URL, but we should accept various feed URLs gently.


Expected results:

Hourly Google Hot Trends top 10 should come! This bug will be fixed by the following patch. Enjoy!
Component: General → Feed Reader
Product: Thunderbird → MailNews Core

Comment 1

5 years ago
alta88 can you look at the patch what it is trying to accomplish? And it isn't in the proper format yet.

TB18 refuses to add this feed in the Subscription dialog.

Updated

5 years ago
Attachment #660355 - Attachment is patch: true
Attachment #660355 - Flags: feedback?(alta88)

Comment 2

5 years ago
Confirming on trunk:

Thu Sep 13 2012 00:22:12
Error: linkElements is null
Source file: chrome://messenger-newsblog/content/feed-parser.js
Line: 635
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: x86 → All
(Assignee)

Comment 3

5 years ago
Created attachment 660489 [details] [diff] [review]
patch


thanks kawamoto, but the patch isn't the right way to avoid the lack of check.  returning/checking for null is inherent to other parsing logic.

fix included.  it may be a year before it's released though.
Assignee: nobody → alta88
Attachment #660355 - Attachment is obsolete: true
Attachment #660355 - Flags: feedback?(alta88)
Attachment #660489 - Flags: review?(mconley)
(Reporter)

Comment 4

5 years ago
Hi alta88, thank you for the fix. It's OK for me about release date.

Thanks again,
Yoshihisa Kawamoto
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Comment 5

5 years ago
Yoshihisa Kawamoto, please do not close the bug, the correct patch was not yet accepted and merged into Thunderbird code.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Updated

5 years ago
Status: REOPENED → ASSIGNED
(Reporter)

Comment 6

5 years ago
Oh, I'm sorry for that.
Comment on attachment 660489 [details] [diff] [review]
patch

Review of attachment 660489 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me. Thanks!
Attachment #660489 - Flags: review?(mconley) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/8fdbcb519211
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago5 years ago
Flags: in-testsuite?
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 18.0

Comment 9

5 years ago
See also 792657.

If this is really a regression starting at TB15, would it be worth it to push into TB16/17 quickly?
Duplicate of this bug: 792657
(Assignee)

Comment 11

5 years ago
Comment on attachment 660489 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: certain feed subscribes fail.
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky):  zero.
Attachment #660489 - Flags: approval-comm-beta?
Attachment #660489 - Flags: approval-comm-aurora?
Attachment #660489 - Flags: approval-comm-beta?
Attachment #660489 - Flags: approval-comm-beta+
Attachment #660489 - Flags: approval-comm-aurora?
Attachment #660489 - Flags: approval-comm-aurora+
Checked in:

https://hg.mozilla.org/releases/comm-aurora/rev/dc89f93aa4f8
https://hg.mozilla.org/releases/comm-beta/rev/15773ab9a33b
status-thunderbird16: --- → fixed
status-thunderbird17: --- → fixed
You need to log in before you can comment on or make changes to this bug.