If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Windows task bar portion of browser window not getting refreshed properly

VERIFIED FIXED

Status

()

Core
Layout: View Rendering
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: nicene, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
I have Windows task bar on autohide. Sometimes after accessing a webpage, the
task bar does not completely disappear but leaves traces. For instance, the
Windows Start button can still be seen but the rest of the task bar has disappeared.

Comment 1

17 years ago
reporter: a picture is worth a thousand words, but in this case there's one 
that really matters: 'confirmed' please attach a picture.  It'd be nice if you 
also included buildid and stuff, but the picture should have that :)
Assignee: asa → trudelle
Component: Browser-General → XP Toolkit/Widgets
QA Contact: doronr → jrgm

Comment 2

17 years ago
(a) worksforme, and (b) what does mozilla have to do with the Windows taskbar.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 3

17 years ago
> > (a) worksforme, and (b) what does mozilla have to do with the Windows 
> > taskbar.
> 
> (b) because it only happens with Mozilla. See picture attached with other 
> post.

What "other post"?

If you have clearer steps to reproduce and/or an image, then reopen this bug.
Status: RESOLVED → VERIFIED

Comment 4

17 years ago
Andie wrote:
> 
> Is there some kind of group e-mail I should reply to? Sorry I sent the 
> image to timeless@bemail.org.
> 

You just use bugzilla. If you attach that image to the bug report, then 
everyone on the bug report will be notified that it has been attached. 

The image helps a lot, although adding (to the bug report) the exact sequence 
of steps to reproduce is helpful (things such as whether the browser is 
fullscreen maximized or what it's position on the screen is if not maximized,
the build ID of mozilla (even though it is visible in the image), how you
get the taskbar to initial show while at the same time clicking on mozilla
[I don't get that part]). 

All of these things help to understand the nature of the problem, and to 
figure out how to fix it. 

In this case, I expect that this is bug 77654, where other apps (or in this
case part of the desktop) will paint on top of mozilla.

Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 5

17 years ago
Created attachment 33365 [details]
the image of mozilla with windows taskbar drawn on top of it.
(Reporter)

Comment 6

17 years ago
Created attachment 33366 [details]
Screenshot
(Reporter)

Comment 7

17 years ago
Steps taken to produce bug:

Move focus to another full-screen application by moving cursor to autohide 
taskbar. 

Switch focus back to Mozilla using the autohide taskbar. 

Result: Focus switches back to Mozilla but for some reason, taskbar portion of 
screen isn't refreshed. I have to move the cursor down to the taskbar portion to 
force a refresh.

I don't see the kind of effects as found in bug #77654 though.

Comment 8

17 years ago
Is that Windows XP?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 9

17 years ago
Yup, it is - build 2465.

Comment 10

17 years ago
just on XP?  ->hyatt.
Assignee: trudelle → hyatt

Comment 11

17 years ago
no, i got win ME and had the same for some time now, and todays nightly is even
worse: when i move a window over the mozilla window it leaves traces, which
disappear only by resizing/hiding the window or reloading the page.

Comment 12

17 years ago
Dup of a view manager bug
Assignee: hyatt → kmcclusk
Component: XP Toolkit/Widgets → Views
QA Contact: jrgm → petersen
(Assignee)

Comment 13

17 years ago
petersen@netscape.com: Could you try to reproduce with a current build on WIN2K?
I checked in a viewmanager fix yesterday that may have fixed this bug. I can not
reproduce the bug on WINNT.
(Reporter)

Comment 14

17 years ago
I can't reproduce the bug anymore on Build 2001051804, so it does look like the 
bug has been fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 15

17 years ago
Marking verified per last comments.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.