[dev][stage]B2G product page isn't populated with data

RESOLVED INVALID

Status

Socorro
Data request
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: AlinT, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 660389 [details]
Screenshot of the issue.

Go to https://crash-stats.allizom.org/products/B2G or/and https://crash-stats-dev.allizom.org/products/B2G

Expected results:
There should be data on the product page: crash reports & data graph

Actual results:
There is no data on the product page.

Comment 1

6 years ago
No bug here, move on. ;-)

We also don't have data showing up on prod, and this is as expected. The reason there is that we don't have active daily user data for B2G, so we can't paint a graph.

There should be the links to topcrash reports, probably, but we also have no data for those right now, as we expect the reports to have a different channel set than the "default" channel they come in with right now.

There is some data there as https://crash-stats.allizom.org/query/query?product=B2G&version=ALL%3AALL&do_query=1 and https://crash-stats-dev.allizom.org/query/query?product=B2G&version=ALL%3AALL&do_query=1 show, and prod also has only this data.


I'm closing this bug right now, but I wonder if the case of not showing the links to topcrash reports is something we should have a bug on and fix in an upcoming version. Schalk, what's your take on this?
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
The change made for the front page during mobeta now only displays those links for versions for which there is data and is plotted on the graph. Perhaps this is not ideal?

Comment 3

6 years ago
(In reply to Schalk Neethling [:espressive] from comment #2)
> The change made for the front page during mobeta now only displays those
> links for versions for which there is data and is plotted on the graph.
> Perhaps this is not ideal?

I guess the problem is what "there is data" actually means. If that means "there are ADU numbers", then IMHO that's a bug (but one we don't need to fix for 18, going 19 or even 20 is OK). If it means "there are crash numbers", that probably is OK. Still, I'd prefer if the links always show up for version set to be "featured", even if the reports end up being empty (which they do for B2G right now).
You need to log in before you can comment on or make changes to this bug.