Last Comment Bug 790738 - Canvas element not loading on page load
: Canvas element not loading on page load
Status: RESOLVED WORKSFORME
:
Product: Tech Evangelism Graveyard
Classification: Graveyard
Component: English US (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal
: ---
Assigned To: english-us
:
Mentors:
http://areyouahuman.com/
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 13:30 PDT by Adam
Modified: 2015-04-19 23:39 PDT (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
The background not loading issue (32.93 KB, image/png)
2012-09-18 10:06 PDT, Adam
no flags Details
What the tide game should look like (78.11 KB, image/png)
2012-09-18 10:07 PDT, Adam
no flags Details

Description Adam 2012-09-12 13:30:19 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120824154833

Steps to reproduce:

We have an IFrame with 3 canvas elements. One of them is not displaying on page load. You can see an example here: http://areyouahuman.com/ by clicking the start button in the game that appears in the upper right portion of the page. 

Clicking start launches a game with no background instructions. If you do something like lose focus or scroll down and back up, the background loads.

This ONLY happens in firefox 15, no other browsers (that we know of) have issues.


Actual results:

We use 3 canvas elements with 2d context, the background one isn't loading on page load.


Expected results:

All 3 elements should have displayed immediately
Comment 1 Loic 2012-09-13 03:21:28 PDT
Does this happen with all canvas minigames?
I tested and I found the background instructions are not displayed only for this game: http://i.imgur.com/1hG5I.png
Comment 2 Adam 2012-09-13 06:32:16 PDT
It happens with all the games. However, if you do something that causes the background to refresh and then click the game's reset button they will display properly. Only by refreshing the page will you reset the canvas not loading issue.
Comment 3 Loic 2012-09-13 08:44:35 PDT
I'm not able to reproduce the issue in various situations: safe mode, hardware acceleration disabled, Azure disabled.

I tried in FF8, FF15, FF18, only the game I linked is displayed without description, all the others are OK.

Can you try with a new profile, please?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Comment 4 Adam 2012-09-13 09:12:56 PDT
Same issue happens with a new profile. I did not see the issue in my previous version of firefox (14 i think), but I see the issue with ALL the games in ff15. I have reports from 2 others that are having this issue as well. I also saw the issue even in safe mode. 

I did some debugging and found out that the issue only seems to occur in windows. Mountain Lion, Lion, and Snow Leopard OS's worked fine. Both of the reports I got were from users running windows.
Comment 5 Simona B [:simonab] 2012-09-18 08:40:35 PDT
I could only reproduce the reported issue - for the game that was mentioned in Comment 1, the rest of the games loaded properly (on Windows 7 on the latest Nightly and Firefox 15.0.1)

For the game mentioned Comment 1, the background instructions are also not displayed on Chrome 21.0.1180.89 m and Opera 12.02.
Comment 6 Adam 2012-09-18 10:05:06 PDT
Do you have access to a service like crossbrowertesting or browserstack? Using that might eliminate any environment issue's we're having. Also, I think something on our homepage was causing the issue to not appear for you guys. Try using this site: http://demo.areyouahuman.com/tide/ username: 'tide', pass: 'sofreshandsoclean'. I was able to see the issue using browserstack. 

Also, I think I gave you the wrong idea of what the issue is. The issue is not that there are no instructions, which is the case in the game mentioned in comment 1 (it is intended this way), the issue is that the background image is not being displayed (which often contains the instructions). I will attach a screenshot of the issue I am describing. Sorry it took so long for me to realize this. Let me know if it makes sense after looking at the screenshot.

Thanks!
Comment 7 Adam 2012-09-18 10:06:21 PDT
Created attachment 662204 [details]
The background not loading issue
Comment 8 Adam 2012-09-18 10:07:42 PDT
Created attachment 662207 [details]
What the tide game should look like
Comment 9 Adam Stevenson 2014-05-09 09:49:24 PDT
Tested the demo in FF29 and it appears to be working now.

Note You need to log in before you can comment on or make changes to this bug.