Hal.cpp:409: error: ‘sSystemTimeObserver’ was not declared in this scope

RESOLVED FIXED

Status

()

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: ameyabap, Assigned: jruderman)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.89 Safari/537.1

Steps to reproduce:

I did hg pull -u to get  latest changes in mozilla-central directory. i tried to compile code by make -f client.mk on linux ubuntu platform.


Actual results:

I got following errors during compilation: The respective file seems to be modified in recent time.
Errors
1.  /mozilla-central/hal/Hal.cpp:409: error: ‘sSystemTimeObserver’ was not declared in this scope

It could be because of template decalration failed. Please suggest necessary patch or repair to it.
Summary: Compile Time Error in latest repository of mozilla-central → Hal.cpp:409: error: ‘sSystemTimeObserver’ was not declared in this scope
This is using C++10 syntax. Do we require a C++10 compiler now?
Blocks: 714358
(Assignee)

Comment 3

6 years ago
I'm guessing this is the same problem:

/Users/jruderman/mozilla-central/hal/Hal.cpp:409:51: error: a space is required
      between consecutive right angle brackets (use '> >')
static StaticAutoPtr<ObserverList<SystemTimeChange>> sSystemTimeObserver;
                                                  ^~
                                                  > >

/usr/bin/clang++ --version
Apple clang version 3.0 (tags/Apple/clang-211.12) (based on LLVM 3.0svn)
Target: x86_64-apple-darwin11.4.0
Thread model: posix

Ameya, does https://hg.mozilla.org/mozilla-central/rev/657097e4f430 fix it for you?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Component: Untriaged → DOM: Device Interfaces
Product: Firefox → Core
Version: 18 Branch → Trunk
(Assignee)

Updated

6 years ago
Assignee: nobody → jruderman
(Reporter)

Comment 4

6 years ago
(In reply to Jesse Ruderman from comment #3)

> Ameya, does https://hg.mozilla.org/mozilla-central/rev/657097e4f430 fix it
> for you?
Yes... It seems '<<' to '< <' change is working. Thanks..
No longer blocks: 791962
You need to log in before you can comment on or make changes to this bug.